cancel
Showing results for 
Search instead for 
Did you mean: 

Magento 1.7.0.2 on PHP 5.6

Re: Magento 1.7.0.2 on PHP 5.6

Hello,

 

The problem is that PHP editions prior to 5.5 are not supported and my ISP needs to upgrade to PHP 5.6. On the other hand, I don't consider that I should upgrade a live online store to Magento CE 1.9.3 just for the sake of PHP 5.6, given that Magento CE 1.7.0.2 currently covers my own needs. Magento upgrade needs a lot of effort (especially the testing part), while I have a large number of extensions and also a Theme which I need to buy again, install and test them.

Re: Magento 1.7.0.2 on PHP 5.6

Hi @dandrikop@Pronto is correct. The patch is only for security fixes. You'll need to upgrade to 1.9.3 if you want the improvements that come with that version, including support for PHP 5.6. Your alternative is to go through and make the needed changes manually using something like Inchoo's PHP 7 extension: http://inchoo.net/magento/its-alive/

--

Community Manager, Magento
Problem solved? Click Accept as Solution!
Still stuck? Check out our documentation: https://magento.com/resources/technical

Re: Magento 1.7.0.2 on PHP 5.6

Would you say that SUPEE 8788 does not include PHP 5.6 patch for 1.7.0.2 versions?
Would it be safe to upgrade php to 5.6 on magento 1.7 without using Inchoo extension?