cancel
Showing results for 
Search instead for 
Did you mean: 

Magento 1.9.1 or 1.9.0 suggestion needed for PHP version and extension compatibility

Magento 1.9.1 or 1.9.0 suggestion needed for PHP version and extension compatibility

Hello,

 

I need to set up a new Magento installation for upcoming shop and I am thinking if I should install 1.9.1 or 1.9.0.

 

The problem is that my main hosting only use PHP 5.3 and Magento 1.9.1 set requirements for PHP 5.4. or PHP 5.5.

I also see that most extension in the market are still only compatible with Magento 1.9.0 and do not work yet with 1.9.1

 

Within my very first tests did not seem to find any problem with 1.9.1 on PHP 5.3 , do you think is too risky to go on builing it on such PHP release and I may get problems the future?

 

May I simply find another host for PHP 5.4 - 5.5  for Magento 1.9.1 and ask developer to upgrade their  extensions for me/ wait until most get updated?

 

Or I just install Magento 1.9.0 with safety patch on PHP 5.3 and start building the shop already compatible with most extension needed?

 

Thanks for sharing your thoughts

 

1 REPLY

Re: Magento 1.9.1 or 1.9.0 suggestion needed for PHP version and extension compatibility

You should install and run the latest 1.9.1.1 version with the patch SUPEE-5994 applied as well. There are no issues running 1.9.1.1 with PHP 5.3, although if you can run on PHP 5.4 or 5.5, you'll see performance improvements. We have many hosting clients running 1.9.1.1 on PHP 5.3 with no issues.

 

Almost all extensions that work with 1.9.0 will work fine with 1.9.1.1.

 

If you do end up going with 1.9.0, make sure you apply *ALL* security patches (SUPEE-1533,5344,5994) right after installing it.