cancel
Showing results for 
Search instead for 
Did you mean: 

Magento upgrade issues from 1.9.2.4

Magento upgrade issues from 1.9.2.4

Hi,

 

I am having trouble updating Magento to newest version. I think it has something to do with following but not sure how to fix.

 

I have updated to Magento 1.9 by uploading a clean 1.9 file set to my server and then attach the old database under it. I followed this methoud because of issues with SSH updae. Upgrade went well except for few Extension and Template issues but the shop runs great without any issues. Because I now want to keep everything up-to-date I want to upgrade to 1.9.3. I follow these steps to do it:

 

cd mydomain.nl
chmod 550 mage
./mage mage-setup .
./mage config-set preferred_state stable
./mage sync
./mage install http://connect20.magentocommerce.com/community Mage_All_Latest --force
php shell/indexer.php reindexall
rm -rf downloader/.cache/ var/cache/

 

I can't get it to work. These are the issues:

 

PHP Warning: scandir(/var/www/vhosts/mydomain.com/httpdocs/staging/./includes): failed to open dir: No such file or directory in /var/www/vhosts/mydomain.com/httpdocs/staging/downloader/lib/Mage/Connect/Packager.php on line 243
PHP Warning: scandir(): (errno 2): No such file or directory in /var/www/vhosts/mydomain.com/httpdocs/staging/downloader/lib/Mage/Connect/Packager.php on line 243

 

Next to that I see when looking at the pkginfo directory it doesn't create a file named Mage_All_Latest.txt but instead it creates a directory call like that.

 

Any clues on where I could look to solve this?

 

Thanks,

Marco

Tags (1)
4 REPLIES

Re: Magento upgrade issues from 1.9.2.4

I have the same problem.

Re: Magento upgrade issues from 1.9.2.4

In my case the issue was because of a server setting. I had to set the open_basedit to no on my server and that solved it.

Re: Magento upgrade issues from 1.9.2.4

I have select open_base to no on my server and don´t solved it.

Re: Magento upgrade issues from 1.9.2.4

Many errors. If it is really a difficult problem and you need to run new site, you can consider Magento upgrade guide by third party as an alternative choice. Hope it helpful for you.