cancel
Showing results for 
Search instead for 
Did you mean: 

Problem Saving Product Data Changes After Upgrade to 1.9.3.1

Problem Saving Product Data Changes After Upgrade to 1.9.3.1

We have an issue since upgrading to version 1.9.3.1. We simply edit some product data and try to press save. Nothing happens. Any advice?

7 REPLIES

Re: Problem Saving Product Data Changes After Upgrade to 1.9.3.1

Hi @ukdig,

 

Has your store core modifications?

Are you using 3rd-party modules?

 

 

--
If you've found one of my answers useful, please give "Kudos" or "Accept as Solution"

Re: Problem Saving Product Data Changes After Upgrade to 1.9.3.1

No core mods but theme mods and also many 3rd party extensions, upwards of twenty.

Re: Problem Saving Product Data Changes After Upgrade to 1.9.3.1

Is it possible for you to check the store with those modules disabled?

If not, you can check for magento system and exception logs. Also, take a look to your webserver error log.

--
If you've found one of my answers useful, please give "Kudos" or "Accept as Solution"

Re: Problem Saving Product Data Changes After Upgrade to 1.9.3.1

Not really, it is a live install with 3 websites on it. I have looked at the exception logs and can not see anything that wpuld possibly caus the issue. I have looked at the console and then tries the save action... result ...  ReferenceError: freeitemadd is not defined.  Line 1 col 1 <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd"> 

Re: Problem Saving Product Data Changes After Upgrade to 1.9.3.1

And does you system log says anything useful?

Re: Problem Saving Product Data Changes After Upgrade to 1.9.3.1

The only thing that shows up  a lot is this error:

Warning: simplexml_load_string(): e&lt;?xml version=&quot;1.0&quot;?&gt; in /lib/Varien/Simplexml/Config.php on line 510

Re: Problem Saving Product Data Changes After Upgrade to 1.9.3.1

I got similar problem and checked Apache logs. and I found Amasty Follow Up Email 1.7.1 is creating the issue in M1931.

 

AH01071: Got error 'PHP message: PHP Fatal error:  Call to a member function getData() on null

 

so check your server logs.