cancel
Showing results for 
Search instead for 
Did you mean: 

Strange 404 Error after installing SUPEE-5994

Strange 404 Error after installing SUPEE-5994

Hi guys,

 

I have installed the 5994 patch on three of my websites. One use version 1.8.0.0 ,  and other two(A & B) use 1.7.0.2.

 

After installing, the version 1.8 is all right. But there is a big problem on the other two 1.7 websites. The frontend are both ok on two websites. But when I click 'orders' and 'manage products' in the admin, both pages of A got the 404 error. The most strange thing is that I can visit the 'orders' page of B. 'manage products' still got 404 error.  A&B has the same configuration and same extension installed. 

 

I tried to revert the patch, but both frontend and admin became blank after I did that. I have to patch it again. 

 

Can someone help?

4 REPLIES

Re: Strange 404 Error after installing SUPEE-5994

If you're using third party modules from developers that kind of missed using proper security programming practices, that can happen (404 not found) in the admin backend when you access anything the module has modified after installing SUPEE-5994. Time to demand a module update from the developer.

 

http://magento.stackexchange.com/questions/68411/patch-5994-causing-module-adminhtml-404

 

 

Re: Strange 404 Error after installing SUPEE-5994

So I need to download the original version of 1.7.0.2 and make a comparison. Find the third party modules and test. Am I right?

Re: Strange 404 Error after installing SUPEE-5994

Thank you. I've fixed the error. Easy but time consuming. 

Re: Strange 404 Error after installing SUPEE-5994

how to fixed, ? can you Please tell the solution here ?

Ubed Arab