cancel
Showing results for 
Search instead for 
Did you mean: 

Upgrade from 1.7 to 1.9.2.4 results in "General error: 2006 MySQL server has gone away."

Upgrade from 1.7 to 1.9.2.4 results in "General error: 2006 MySQL server has gone away."

I ran the upgrade using Magento Connect Manager and it ended with the this error printed twice. The console output from the upgrade process is below. Can anyone help meget this fixed or do I have to reinstall Magento?

 


Checking dependencies of packages
Starting to download Lib_LinLibertineFont-2.8.14.5.tgz ...
...done: 2,215,366 bytes
Installing package community/Lib_LinLibertineFont 2.8.14.5
Package community/Lib_LinLibertineFont 2.8.14.5 installed successfully
Starting to download Lib_Js_Calendar-1.51.1.5.tgz ...
...done: 25,117 bytes
Installing package community/Lib_Js_Calendar 1.51.1.5
Package community/Lib_Js_Calendar 1.51.1.5 installed successfully
Starting to download Lib_Magento-1.9.2.4.tgz ...
...done: 12,617 bytes
Installing package community/Lib_Magento 1.9.2.4
Package community/Lib_Magento 1.9.2.4 installed successfully
Starting to download Lib_Credis-1.9.2.4.tgz ...
...done: 8,655 bytes
Installing package community/Lib_Credis 1.9.2.4
Package community/Lib_Credis 1.9.2.4 installed successfully
Starting to download Lib_Pelago-1.9.2.4.tgz ...
...done: 7,760 bytes
Installing package community/Lib_Pelago 1.9.2.4
Package community/Lib_Pelago 1.9.2.4 installed successfully
Starting to download Lib_Unserialize-1.9.2.4.tgz ...
...done: 2,925 bytes
Installing package community/Lib_Unserialize 1.9.2.4
Package community/Lib_Unserialize 1.9.2.4 installed successfully
Starting to download Lib_IDNA2-1.9.2.4.tgz ...
...done: 21,075 bytes
Installing package community/Lib_IDNA2 1.9.2.4
Package community/Lib_IDNA2 1.9.2.4 installed successfully
Package upgraded:
 community Lib_LinLibertineFont 2.8.14.5
 community Lib_Js_Calendar 1.51.1.5
 community Lib_Magento 1.9.2.4
 community Lib_Credis 1.9.2.4
 community Lib_Pelago 1.9.2.4
 community Lib_Unserialize 1.9.2.4
 community Lib_IDNA2 1.9.2.4

CONNECT ERROR: Package community/Interface_Adminhtml_Default 1.9.2.4 conflicts with: community/Mage_All_Latest 1.7.0.2
Package community/Mage_Core_Adminhtml 1.9.2.4 conflicts with: community/Interface_Adminhtml_Default 1.7.0.1, community/Mage_All_Latest 1.7.0.2, community/Mage_Compiler 1.7.0.0
Package community/Mage_Core_Modules 1.9.2.4 conflicts with: community/Interface_Frontend_Base_Default 1.7.0.1, community/Interface_Frontend_Default 1.7.0.0, community/Interface_Install_Default 1.7.0.0, community/Mage_All_Latest 1.7.0.2, community/Mage_Centinel 1.7.0.0, community/Mage_Compiler 1.7.0.0, community/Mage_Core_Adminhtml 1.7.0.1, community/Magento_Mobile 1.7.0.1.22.1, community/Phoenix_Moneybookers 1.3.1
Package community/Lib_Js_Ext 1.9.2.4 conflicts with: community/Interface_Adminhtml_Default 1.7.0.1, community/Mage_Core_Adminhtml 1.7.0.1
Package community/Lib_Js_TinyMCE 3.5.11.4 conflicts with: community/Mage_Core_Adminhtml 1.7.0.1
Package community/Lib_Varien 1.9.2.4 conflicts with: community/Mage_Core_Modules 1.7.0.2
Package community/Lib_Google_Checkout 1.9.2.4 conflicts with: community/Mage_Core_Modules 1.7.0.2
Package community/Lib_Js_Mage 1.9.2.4 conflicts with: community/Mage_Core_Modules 1.7.0.2
Package community/Lib_Phpseclib 1.9.2.4 conflicts with: community/Mage_Core_Modules 1.7.0.2
Package community/Mage_Locale_en_US 1.9.2.4 conflicts with: community/Mage_Core_Modules 1.7.0.2
Package community/Lib_Mage 1.9.2.4 conflicts with: community/Mage_Core_Modules 1.7.0.2
Package community/Lib_ZF 1.12.10.4 conflicts with: community/Lib_Varien 1.7.0.0
Package community/Lib_Js_Prototype 1.9.2.4 conflicts with: community/Lib_Js_Mage 1.7.0.1, community/Mage_Core_Modules 1.7.0.2
Package community/Lib_ZF_Locale 1.12.10.4 conflicts with: community/Lib_ZF 1.11.1.0

Checking dependencies of packages
Already installed: community/Lib_Js_Calendar 1.51.1.5, skipping
Already installed: community/Lib_Magento 1.9.2.4, skipping
Already installed: community/Lib_Credis 1.9.2.4, skipping
Already installed: community/Lib_Pelago 1.9.2.4, skipping
Already installed: community/Lib_Unserialize 1.9.2.4, skipping
Already installed: community/Lib_IDNA2 1.9.2.4, skipping

CONNECT ERROR: Package community/Interface_Frontend_Base_Default 1.9.2.4 conflicts with: community/Mage_All_Latest 1.7.0.2
Package community/Mage_Core_Modules 1.9.2.4 conflicts with: community/Interface_Frontend_Base_Default 1.7.0.1, community/Interface_Frontend_Default 1.7.0.0, community/Interface_Install_Default 1.7.0.0, community/Mage_All_Latest 1.7.0.2, community/Mage_Centinel 1.7.0.0, community/Mage_Compiler 1.7.0.0, community/Mage_Core_Adminhtml 1.7.0.1, community/Magento_Mobile 1.7.0.1.22.1, community/Phoenix_Moneybookers 1.3.1
Package community/Lib_Varien 1.9.2.4 conflicts with: community/Mage_Core_Modules 1.7.0.2
Package community/Lib_Google_Checkout 1.9.2.4 conflicts with: community/Mage_Core_Modules 1.7.0.2
Package community/Lib_Js_Mage 1.9.2.4 conflicts with: community/Mage_Core_Modules 1.7.0.2
Package community/Lib_Phpseclib 1.9.2.4 conflicts with: community/Mage_Core_Modules 1.7.0.2
Package community/Mage_Locale_en_US 1.9.2.4 conflicts with: community/Mage_Core_Modules 1.7.0.2
Package community/Lib_Mage 1.9.2.4 conflicts with: community/Mage_Core_Modules 1.7.0.2
Package community/Lib_ZF 1.12.10.4 conflicts with: community/Lib_Varien 1.7.0.0
Package community/Lib_Js_Prototype 1.9.2.4 conflicts with: community/Lib_Js_Mage 1.7.0.1, community/Mage_Core_Modules 1.7.0.2
Package community/Lib_ZF_Locale 1.12.10.4 conflicts with: community/Lib_ZF 1.11.1.0

Checking dependencies of packages
Already installed: community/Lib_Js_Calendar 1.51.1.5, skipping
Already installed: community/Lib_Magento 1.9.2.4, skipping
Already installed: community/Lib_Credis 1.9.2.4, skipping
Already installed: community/Lib_Pelago 1.9.2.4, skipping
Already installed: community/Lib_Unserialize 1.9.2.4, skipping
Already installed: community/Lib_IDNA2 1.9.2.4, skipping

CONNECT ERROR: Package community/Interface_Frontend_Default 1.9.2.4 conflicts with: community/Mage_All_Latest 1.7.0.2
Package community/Mage_Core_Modules 1.9.2.4 conflicts with: community/Interface_Frontend_Base_Default 1.7.0.1, community/Interface_Frontend_Default 1.7.0.0, community/Interface_Install_Default 1.7.0.0, community/Mage_All_Latest 1.7.0.2, community/Mage_Centinel 1.7.0.0, community/Mage_Compiler 1.7.0.0, community/Mage_Core_Adminhtml 1.7.0.1, community/Magento_Mobile 1.7.0.1.22.1, community/Phoenix_Moneybookers 1.3.1
Package community/Lib_Varien 1.9.2.4 conflicts with: community/Mage_Core_Modules 1.7.0.2
Package community/Lib_Google_Checkout 1.9.2.4 conflicts with: community/Mage_Core_Modules 1.7.0.2
Package community/Lib_Js_Mage 1.9.2.4 conflicts with: community/Mage_Core_Modules 1.7.0.2
Package community/Lib_Phpseclib 1.9.2.4 conflicts with: community/Mage_Core_Modules 1.7.0.2
Package community/Mage_Locale_en_US 1.9.2.4 conflicts with: community/Mage_Core_Modules 1.7.0.2
Package community/Lib_Mage 1.9.2.4 conflicts with: community/Mage_Core_Modules 1.7.0.2
Package community/Lib_ZF 1.12.10.4 conflicts with: community/Lib_Varien 1.7.0.0
Package community/Lib_Js_Prototype 1.9.2.4 conflicts with: community/Lib_Js_Mage 1.7.0.1, community/Mage_Core_Modules 1.7.0.2
Package community/Lib_ZF_Locale 1.12.10.4 conflicts with: community/Lib_ZF 1.11.1.0

Checking dependencies of packages
Already installed: community/Lib_Js_Calendar 1.51.1.5, skipping
Already installed: community/Lib_Magento 1.9.2.4, skipping
Already installed: community/Lib_Credis 1.9.2.4, skipping
Already installed: community/Lib_Pelago 1.9.2.4, skipping
Already installed: community/Lib_Unserialize 1.9.2.4, skipping
Already installed: community/Lib_IDNA2 1.9.2.4, skipping

CONNECT ERROR: Package community/Interface_Install_Default 1.9.2.4 conflicts with: community/Mage_All_Latest 1.7.0.2
Package community/Mage_Core_Modules 1.9.2.4 conflicts with: community/Interface_Frontend_Base_Default 1.7.0.1, community/Interface_Frontend_Default 1.7.0.0, community/Interface_Install_Default 1.7.0.0, community/Mage_All_Latest 1.7.0.2, community/Mage_Centinel 1.7.0.0, community/Mage_Compiler 1.7.0.0, community/Mage_Core_Adminhtml 1.7.0.1, community/Magento_Mobile 1.7.0.1.22.1, community/Phoenix_Moneybookers 1.3.1
Package community/Lib_Varien 1.9.2.4 conflicts with: community/Mage_Core_Modules 1.7.0.2
Package community/Lib_Google_Checkout 1.9.2.4 conflicts with: community/Mage_Core_Modules 1.7.0.2
Package community/Lib_Js_Mage 1.9.2.4 conflicts with: community/Mage_Core_Modules 1.7.0.2
Package community/Lib_Phpseclib 1.9.2.4 conflicts with: community/Mage_Core_Modules 1.7.0.2
Package community/Mage_Locale_en_US 1.9.2.4 conflicts with: community/Mage_Core_Modules 1.7.0.2
Package community/Lib_Mage 1.9.2.4 conflicts with: community/Mage_Core_Modules 1.7.0.2
Package community/Lib_ZF 1.12.10.4 conflicts with: community/Lib_Varien 1.7.0.0
Package community/Lib_Js_Prototype 1.9.2.4 conflicts with: community/Lib_Js_Mage 1.7.0.1, community/Mage_Core_Modules 1.7.0.2
Package community/Lib_ZF_Locale 1.12.10.4 conflicts with: community/Lib_ZF 1.11.1.0

Checking dependencies of packages

CONNECT ERROR: Package community/Lib_Google_Checkout 1.9.2.4 conflicts with: community/Mage_Core_Modules 1.7.0.2

Checking dependencies of packages
Already installed: community/Lib_Js_Calendar 1.51.1.5, skipping

Cleaning cache

Checking dependencies of packages
..
CONNECT ERROR: Package community/Lib_Js_Ext 1.9.2.4 conflicts with: community/Interface_Adminhtml_Default 1.7.0.1, community/Mage_Core_Adminhtml 1.7.0.1

Checking dependencies of packages
...
CONNECT ERROR: Package community/Lib_Js_Mage 1.9.2.4 conflicts with: community/Mage_Core_Modules 1.7.0.2
Package community/Lib_Js_Prototype 1.9.2.4 conflicts with: community/Lib_Js_Mage 1.7.0.1, community/Mage_Core_Modules 1.7.0.2

Checking dependencies of packages
.
CONNECT ERROR: Package community/Lib_Js_Prototype 1.9.2.4 conflicts with: community/Lib_Js_Mage 1.7.0.1, community/Mage_Core_Modules 1.7.0.2
.
Checking dependencies of packages
.
CONNECT ERROR: Package community/Lib_Js_TinyMCE 3.5.11.4 conflicts with: community/Mage_Core_Adminhtml 1.7.0.1

Checking dependencies of packages
..Already installed: community/Lib_LinLibertineFont 2.8.14.5, skipping

Cleaning cache

Checking dependencies of packages
..
CONNECT ERROR: Package community/Lib_Mage 1.9.2.4 conflicts with: community/Mage_Core_Modules 1.7.0.2

Checking dependencies of packages
..
CONNECT ERROR: Package community/Lib_Phpseclib 1.9.2.4 conflicts with: community/Mage_Core_Modules 1.7.0.2

Checking dependencies of packages
.............
CONNECT ERROR: Package community/Lib_Varien 1.9.2.4 conflicts with: community/Mage_Core_Modules 1.7.0.2
Package community/Lib_ZF 1.12.10.4 conflicts with: community/Lib_Varien 1.7.0.0
Package community/Lib_ZF_Locale 1.12.10.4 conflicts with: community/Lib_ZF 1.11.1.0
..........
Checking dependencies of packages

CONNECT ERROR: Package community/Lib_ZF 1.12.10.4 conflicts with: community/Lib_Varien 1.7.0.0
Package community/Lib_ZF_Locale 1.12.10.4 conflicts with: community/Lib_ZF 1.11.1.0

Checking dependencies of packages
....
CONNECT ERROR: Package community/Lib_ZF_Locale 1.12.10.4 conflicts with: community/Lib_ZF 1.11.1.0

Checking dependencies of packages
...........................................................................................................Starting to download Mage_All_Latest-1.9.2.4.tgz ...
....done: 726 bytes
Installing package community/Mage_All_Latest 1.9.2.4
Package community/Mage_All_Latest 1.9.2.4 installed successfully
.Starting to download Interface_Adminhtml_Default-1.9.2.4.tgz ...
.......done: 1,014,584 bytes
...Installing package community/Interface_Adminhtml_Default 1.9.2.4
...Package community/Interface_Adminhtml_Default 1.9.2.4 installed successfully
.Starting to download Interface_Frontend_Default-1.9.2.4.tgz ...
......done: 747,764 bytes
Installing package community/Interface_Frontend_Default 1.9.2.4
.Package community/Interface_Frontend_Default 1.9.2.4 installed successfully
.Starting to download Interface_Install_Default-1.9.2.4.tgz ...
.....done: 108,387 bytes
Installing package community/Interface_Install_Default 1.9.2.4
.Package community/Interface_Install_Default 1.9.2.4 installed successfully
.Starting to download Mage_Downloader-1.9.2.4.tgz ...
.....done: 285,339 bytes
..Installing package community/Mage_Downloader 1.9.2.4
Package community/Mage_Downloader 1.9.2.4 installed successfully
.Starting to download Mage_Centinel-1.9.2.4.tgz ...
....done: 38,515 bytes
.Installing package community/Mage_Centinel 1.9.2.4
.Package community/Mage_Centinel 1.9.2.4 installed successfully
.Starting to download Interface_Frontend_Base_Default-1.9.2.4.tgz ...
.....done: 401,221 bytes
...Installing package community/Interface_Frontend_Base_Default 1.9.2.4
..Package community/Interface_Frontend_Base_Default 1.9.2.4 installed successfully
..Starting to download Phoenix_Moneybookers-1.9.2.4.tgz ...
.....done: 364,403 bytes
.Installing package community/Phoenix_Moneybookers 1.9.2.4
Package community/Phoenix_Moneybookers 1.9.2.4 installed successfully
.Starting to download Mage_Compiler-1.9.2.4.tgz ...
.....done: 10,238 bytes
Installing package community/Mage_Compiler 1.9.2.4
Package community/Mage_Compiler 1.9.2.4 installed successfully
.Starting to download Magento_Mobile-1.9.2.4.tgz ...
.......done: 2,126,835 bytes
..Installing package community/Magento_Mobile 1.9.2.4
...Package community/Magento_Mobile 1.9.2.4 installed successfully
.Starting to download Lib_Cm-1.9.2.4.tgz ...
....done: 8,026 bytes
Installing package community/Lib_Cm 1.9.2.4
Package community/Lib_Cm 1.9.2.4 installed successfully
..Starting to download Cm_RedisSession-1.9.2.4.tgz ...
....done: 8,360 bytes
Installing package community/Cm_RedisSession 1.9.2.4
Package community/Cm_RedisSession 1.9.2.4 installed successfully
.Starting to download Interface_Frontend_Rwd_Default-1.9.2.4.tgz ...
......done: 736,756 bytes
.Installing package community/Interface_Frontend_Rwd_Default 1.9.2.4
..Package community/Interface_Frontend_Rwd_Default 1.9.2.4 installed successfully
..Starting to download Mage_Core_Adminhtml-1.9.2.4.tgz ...
......done: 537,127 bytes
.....Installing package community/Mage_Core_Adminhtml 1.9.2.4
.....Package community/Mage_Core_Adminhtml 1.9.2.4 installed successfully
.Starting to download Mage_Core_Modules-1.9.2.4.tgz ...
.........done: 3,249,522 bytes
................Installing package community/Mage_Core_Modules 1.9.2.4
..........................Package community/Mage_Core_Modules 1.9.2.4 installed successfully
Starting to download Lib_Js_Ext-1.9.2.4.tgz ...
.....done: 266,234 bytes
..Installing package community/Lib_Js_Ext 1.9.2.4
Package community/Lib_Js_Ext 1.9.2.4 installed successfully
.Already installed: community/Lib_LinLibertineFont 2.8.14.5, skipping
Starting to download Lib_Js_TinyMCE-3.5.11.4.tgz ...
......done: 1,188,484 bytes
..Installing package community/Lib_Js_TinyMCE 3.5.11.4
...Package community/Lib_Js_TinyMCE 3.5.11.4 installed successfully
.Starting to download Lib_Varien-1.9.2.4.tgz ...
.....done: 158,103 bytes
.Installing package community/Lib_Varien 1.9.2.4
.Package community/Lib_Varien 1.9.2.4 installed successfully
.Starting to download Lib_Google_Checkout-1.9.2.4.tgz ...
....done: 466 bytes
..Installing package community/Lib_Google_Checkout 1.9.2.4
Package community/Lib_Google_Checkout 1.9.2.4 installed successfully
Already installed: community/Lib_Js_Calendar 1.51.1.5, skipping
Starting to download Lib_Js_Mage-1.9.2.4.tgz ...
.....done: 293,385 bytes
.Installing package community/Lib_Js_Mage 1.9.2.4
Package community/Lib_Js_Mage 1.9.2.4 installed successfully
.Starting to download Lib_Phpseclib-1.9.2.4.tgz ...
......done: 109,937 bytes
.Installing package community/Lib_Phpseclib 1.9.2.4
Package community/Lib_Phpseclib 1.9.2.4 installed successfully
.Starting to download Mage_Locale_en_US-1.9.2.4.tgz ...
.....done: 102,156 bytes
.Installing package community/Mage_Locale_en_US 1.9.2.4
Package community/Mage_Locale_en_US 1.9.2.4 installed successfully
.Starting to download Lib_Mage-1.9.2.4.tgz ...
....done: 78,768 bytes
.Installing package community/Lib_Mage 1.9.2.4
Package community/Lib_Mage 1.9.2.4 installed successfully
.Already installed: community/Lib_Magento 1.9.2.4, skipping
Already installed: community/Lib_Credis 1.9.2.4, skipping
Already installed: community/Lib_Pelago 1.9.2.4, skipping
Already installed: community/Lib_Unserialize 1.9.2.4, skipping
Already installed: community/Lib_IDNA2 1.9.2.4, skipping
Starting to download Lib_ZF-1.12.10.4.tgz ...
.........done: 4,805,049 bytes
........Installing package community/Lib_ZF 1.12.10.4
.............Package community/Lib_ZF 1.12.10.4 installed successfully
.Starting to download Lib_Js_Prototype-1.9.2.4.tgz ...
.....done: 233,325 bytes
Installing package community/Lib_Js_Prototype 1.9.2.4
.Package community/Lib_Js_Prototype 1.9.2.4 installed successfully
.Starting to download Lib_ZF_Locale-1.12.10.4.tgz ...
.......done: 3,464,225 bytes
....Installing package community/Lib_ZF_Locale 1.12.10.4
.......Package community/Lib_ZF_Locale 1.12.10.4 installed successfully
.Package upgraded:
 community Mage_All_Latest 1.9.2.4
 community Interface_Adminhtml_Default 1.9.2.4
 community Interface_Frontend_Default 1.9.2.4
 community Interface_Install_Default 1.9.2.4
 community Mage_Downloader 1.9.2.4
 community Mage_Centinel 1.9.2.4
 community Interface_Frontend_Base_Default 1.9.2.4
 community Phoenix_Moneybookers 1.9.2.4
 community Mage_Compiler 1.9.2.4
 community Magento_Mobile 1.9.2.4
 community Lib_Cm 1.9.2.4
 community Cm_RedisSession 1.9.2.4
 community Interface_Frontend_Rwd_Default 1.9.2.4
 community Mage_Core_Adminhtml 1.9.2.4
 community Mage_Core_Modules 1.9.2.4
 community Lib_Js_Ext 1.9.2.4
 community Lib_Js_TinyMCE 3.5.11.4
 community Lib_Varien 1.9.2.4
 community Lib_Google_Checkout 1.9.2.4
 community Lib_Js_Mage 1.9.2.4
 community Lib_Phpseclib 1.9.2.4
 community Mage_Locale_en_US 1.9.2.4
 community Lib_Mage 1.9.2.4
 community Lib_ZF 1.12.10.4
 community Lib_Js_Prototype 1.9.2.4
 community Lib_ZF_Locale 1.12.10.4

Cleaning cache

Checking dependencies of packages

Exception during cache and session cleaning................................................
Exception during cache and session cleaning: SQLSTATE[HY000]: General error: 2006 MySQL server has gone away.
Exception during cache and session cleaning: SQLSTATE[HY000]: General error: 2006 MySQL server has gone away

3 REPLIES

Re: Upgrade from 1.7 to 1.9.2.4 results in "General error: 2006 MySQL server has gone away.&quo

Hi,
I would suggest you not to upgrade all the magento extensions at once, rather try upgrading "Mage_All_Latest" first. It will overcome the issue.

If still you find problem, let me know again with the details.

Re: Upgrade from 1.7 to 1.9.2.4 results in "General error: 2006 MySQL server has gone away.&amp

I am getting 500 error when trying to login to the admin area. I don't know how to rollback the changes or fix the 500 error. I thnk the 500 error is related to the mysql connection being lost, but don;t know where the connection details are or what the should be.

Re: Upgrade from 1.7 to 1.9.2.4 results in "General error: 2006 MySQL server has gone away.&amp

I got the 500 error after upgrading as well. I set the index.php to 644 permissions and that cleared it up