cancel
Showing results for 
Search instead for 
Did you mean: 

Upgrade from 1.7 to 1.9 WYSIWYG Editor Show/Hide Problem

Upgrade from 1.7 to 1.9 WYSIWYG Editor Show/Hide Problem

After the upgrade, the show/hide button no longer works at all.

Not sure if it is a jquery + prototype.js conflict or not.

Not sure if it is a conflict among extensions/plugins.

Upon clicking the show/hide button, it seems like no javascript functions are called at all, so maybe a disconnect exists there.

 

Any help is greatly appreciated.

 

Update: The WYSIWYG Editor works when editing pages and static blocks, but not for products

6 REPLIES

Re: Upgrade from 1.7 to 1.9 WYSIWYG Editor Show/Hide Problem

Hi are you using the feature "merge js"?

It seems that is a js error, please check the browser console.

If you don't know how to do it, check this page.

Problem solved? Click Accept as Solution!
Still stuck? Check out our documentation: http://magento.com/help/documentation
Tags (1)

Re: Upgrade from 1.7 to 1.9 WYSIWYG Editor Show/Hide Problem

Please share the error you are getting in console.

If you have enabled javascript merging then please disable it and do clear caching and indexing and then try it.

Found something useful, please give "Kudos" or "Accept as Solution" for Token of Appreciation.
Free Magento Extensions : https://magecomp.com/free-magento-extensions.html

Re: Upgrade from 1.7 to 1.9 WYSIWYG Editor Show/Hide Problem

Enabling the merge javascript function did not help the problem.

 

I have found a couple errors when observing the browser consoles in chrome and firefox:

 

SyntaxError: unreachable code after return statement(error was seen on page load in Firefox)
ReferenceError: editorFormValidationHandler is not defined(error was seen after clicking cancel in the wysiwyg editor)

 

Also, when I create a profile in the browser console to monitor the javascript calls, i still see almost no javascrip calls from the wysiwyg editor. This is unique to only the product descrtiption editor, it works properly elsewhere.

Re: Upgrade from 1.7 to 1.9 WYSIWYG Editor Show/Hide Problem

Hi rnimmo13,

 

You have to be sure that merge feature is disable. Smiley Wink 

 

Please post the console error details and any relevant info, so we can help you further.

 

Problem solved? Click Accept as Solution!
Still stuck? Check out our documentation: http://magento.com/help/documentation

Re: Upgrade from 1.7 to 1.9 WYSIWYG Editor Show/Hide Problem

There are 3 errors i see in the console.

 

SyntaxError: unreachable code after return statement(error was seen on page load in Firefox)


Uncaught ReferenceError: editorFormValidationHandler is not defined(error was seen after clicking cancel in the wysiwyg editor)

 

Uncaught ReferenceError: wysiwygdescription_editor is not defined(error was seen after clicking submit in wysiwyg editor)

 

Im not sure what other information to include; I have tried many solutions such as changing the jquery to use noConflict() but that didnt work, among other proposed solutions. If there is a way to configure the product description to use the tinyMCE files, that would be very useful and worth trying.

Re: Upgrade from 1.7 to 1.9 WYSIWYG Editor Show/Hide Problem

Managed to get a work around fix that should suffice. The button for the wysiwyg editor still doesnt work, but the wysiwyg editor is displayed upon page load into the text box for product description. Does not change the behaviour of pages or static block editors.

 

 Had to go to app/design/adminhtml/defaut/default/template/catalog/product/edit.phtml. and change

 

Event.observe(window, 'load', function() {
var objName = '<?php echo $this->getSelectedTabId() ?>';
if (objName) {
obj = $(objName);
//IE fix (bubbling event model)
product_info_tabsJsTabs.setSkipDisplayFirstTab();
product_info_tabsJsTabs.showTabContent(obj);
}
Product.AttributesBridge.setTabsObject(product_info_tabsJsTabs);
});

 

to

 

Event.observe(window, 'load', function() {
var objName = '<?php echo $this->getSelectedTabId() ?>';
if (objName) {
obj = $(objName);
//IE fix (bubbling event model)
product_info_tabsJsTabs.setSkipDisplayFirstTab();
product_info_tabsJsTabs.showTabContent(obj);
}
Product.AttributesBridge.setTabsObject(product_info_tabsJsTabs);
tinyMCE.init({
mode : "exact",
theme : "advanced",
strict_loading_mode : true,
elements : "description,short_description",
theme_advanced_toolbar_location : "top",
theme_advanced_toolbar_align : "left",
theme_advanced_path_location : "bottom",
extended_valid_elements : "a[name|href|target|title|onclick],img[class|src|border=0|alt|title|hspace|vspace|width|height|align|onmouseover|onmouseout|name],hr[class|width|size|noshade],font[face|size|color|style],span[class|align|style]",
theme_advanced_resize_horizontal : "true",
theme_advanced_resizing : "true",
apply_source_formatting : "true",
convert_urls : "false",
force_br_newlines : "true",
doctype : '<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">'
});
});