cancel
Showing results for 
Search instead for 
Did you mean: 

Whilst upgrading from 1.9.0.1 to 1.9.1.1 I got the following error message 343439524195,

Whilst upgrading from 1.9.0.1 to 1.9.1.1 I got the following error message 343439524195,

Upgrading from 1.9.0.1 to 1.9.1.1 produced the following error:

public_html/app/code/core/Mage/Core/sql/core_setup/upgrade-1.6.0.5-1.6.0.6.php" - SQLSTATE[42S01]: Base table or view already exists: 1050 Table 'mage_core_email_queue' already exists, query was: CREATE TABLE `mage_core_email_queue` (

I had a previous upgrade fail attempt at 1.9.1.0 so rolled back and waited for next update 1.9.1.1, would waiting for a major update solve the problem?

I now have a website fully working but unable to update, any solutions please?

4 REPLIES

Re: Whilst upgrading from 1.9.0.1 to 1.9.1.1 I got the following error message 343439524195,

How did you do upgrade?

It might cached issues and permission of install folder during run installation. 

So just re-start from begin and do step by step to re-install magento again (remove /app/etc/local.xml, remove var/cached)

 

Let me know if you still got same trouble.

Hope this help

Re: Whilst upgrading from 1.9.0.1 to 1.9.1.1 I got the following error message 343439524195,

I use installatron in Cpanel to upgrade, I did what you suggested, but it looked like it was going to try and do a clean install of Magento, so I stopped and did a restore

Re: Whilst upgrading from 1.9.0.1 to 1.9.1.1 I got the following error message 343439524195,

Had the same problem with email tables already existing but I had no previous errors, etc. so I think it's a problem in the installer script(s).

 

Not sure if it's the best advice for everyone.... but since the tables were empty on my installation, I just dropped them and proceeded without issue.  They just get re-created during the upgrade process.

 

Other route would be to change out the PHP in the installer script that's trying to create the tables again and fix that so it doesn't error out. Check to see if the table exists and behave appropriately, etc.

Re: Whilst upgrading from 1.9.0.1 to 1.9.1.1 I got the following error message 343439524195,

Can I ask you how you dropped the tables out. I have a test site set up which has same problem with email table error which I would like to have a go at and see if this fixes the problem