cancel
Showing results for 
Search instead for 
Did you mean: 

Adding a product

Adding a product

Hi,

I'm new to Magento and I'm evaluating Magento right now.

When a click the button "Ad product" under Catalog I receive the message

Spoiler
> An error has happened during application run. See exception log for details.

 

From where comes this error?

 

I already executed

Spoiler
php bin/magento cache:clean
php bin/magento cache:flush
php bin/magento indexer:reindex
php bin/magento setup:upgrade
php bin/magento setup:static-content:deploy -f

But nothing change.

6 REPLIES 6

Re: Adding a product

Hi @lucvigatogd8e7 

 

You can set developer mode to check the error on frontend.

php bin/magento deploy:mode:set developer

And

Enable the error reporting in the following file. 


app/bootstrap.php

Un-comment the below line.

ini_set('display_errors', 1);


I hope it will help you for find the error and fix it!

Re: Adding a product

I receive the error

Exception #0 (ReflectionException): Class StripeIntegration\Payments\Model\Adminhtml\Source\BillingInterval does not exist

But I removed the Stripe Module.

How can I fix this ? 

Re: Adding a product

Hi @lucvigatogd8e7 

 

As you said you removed Stripe Module did you run 

 

php bin/magento setup:di:compile

if not then give it a try.

 

also after this please don't forget to clear cache.

 

Hope this helps.

 

Problem solved? Click Accept as Solution!

Re: Adding a product

I run

php bin/magento setup:di:compile

and i clear the cash

with the commands

bin/magento cache:clean
bin/magento cache:flush

But the error persists

Re: Adding a product

Hi @lucvigatogd8e7 

 

 

In this case can you please check first this module status by command line weather it's enable or disable by using below command:

 

php bin/magento module:status Module_Name

If it's disable then you need to check where you are using this class and remove it from there because you have disabled the module and you are using it's class somewhere else that's why it's throwing error.

 

Hope this helps.

 

 Problem solved? Click Accept as Solution!

Re: Adding a product

I also had similar issues, I wasn't able to open or add new products.

The module StripeIntegration leaves behind some traces in the database so what I did was to go the the database, ran this SQL Query

SELECT * FROM eav_attribute WHERE source_model LIKE '%StripeIntegration%';

since I discovered that what was causing it was some records in the eav_attribute table, then I deleted the results of the query.

 

Hope this helps?

 

Click kudos and Accept as solution.