cancel
Showing results for 
Search instead for 
Did you mean: 

Authorize.net not working

Authorize.net not working

I can't seem to get authorize.net transactions to work. I consistently get the error "Please enter a transaction ID to authorize this payment."; does anyone have authorize.net configured properly and working on Magento2? Or how would I get logs to see what's occurring (my var/log folder is empty; there is no var/reports folder)

5 REPLIES

Re: Authorize.net not working

Have you confirmed with Authorize.net that your transactions are hitting their system?

Magento Moderator since 2009
Keep Calm and Clear Cache!

Re: Authorize.net not working

Thanks for the reply; actually, though, at this time I've stopped my efforts with Magento 2; I'll come back in a few months to a year probably.

From what I recall, I couldn't see any activity that occurred in authorize.net, but I may not have looked through the right logs or location. I could have configured something wrong somewhere though; I guess my main question here was to confirm if anyone else has authorize.net working with Magento 2

Re: Authorize.net not working

To confirm - the current implementation works with Auth.net (DPM) - also works with any other service which supports DPM.

Re: Authorize.net not working

I just ran into the "Please enter a transaction ID to authorize this payment." error message on Magento 2.0.0. My problem was that I was using live credentials but I had the STORES > Configuration > SALES > Payment Methods > Authorize.net Direct Post > Test Mode field set to "Yes". Changing it to "No" fixed my problem.

 

Also, if you want to troubleshoot Authorize.net issues, change the "Debug" option to "Yes" and then look at the var/log/debug.log file.

Re: Authorize.net not working

Can confirm. Magento 2 CE was having the same issue. Setting my Auth.net account to Live, and then setting test mode to No in Magento did the trick.