cancel
Showing results for 
Search instead for 
Did you mean: 

Cannot change language after install language package

Cannot change language after install language package

Version: Magento 2 CE 2.0.6

language package: https://github.com/Magento2Translations/language_zh_cn

 

I have installed the language package. And it shows in the console. But I the front end and admin console still in English.

 

Does anyone know why? Thanks in advance!

 

3 REPLIES

Re: Cannot change language after install language package

Unfortunately I can't provide a solution, but hopefully my post stirs up a little bit more attention. Because I'm facing the same problem. I downloaded https://github.com/splendidinternet/Magento2_German_LocalePack_de_DE and installed it via composer (as described on github). Downloading/installing via composer worked fine. I have 2 store views, 'English' and 'German'. In Admin > Stores > Settings > Configuration > General > Locale Options > Locale I choose the German locale for my 'German' Store View. I uncheck '[ ] Use Website', I save, re-index, flush cache. But nowhere I can spot any single German word. Not in the backend, not in the store. It seems my German language pack gets completely ignored by Magento. 1. How can I "enable" my German language pack? 2. Am I right with my assumption that '[x] Use Website' (which can be frequently found in the Magento Admin) means "Use the information, e.g. preferred language, which a visitors web browser provide"? Thx for any help.

Re: Cannot change language after install language package

Sorry for the messed up formatting of my previous post. I inserted blank lines in my text, but for some reason, they got all removed when I clicked [Post] here in this forum.

Re: Cannot change language after install language package

Finally I can provide a solution

 

 

1. https://github.com/splendidinternet/Magento2_German_LocalePack_de_DE shows 1. a manual install and 2. a composer based install of the language pack. For convenience I used the composer based install, but it did not work for me. Though, the manual install worked.

 

 

2. "[*] Use Website" does NOT refer to a visitor's web browser (which provides a preferred language, e.g. en_US, to the Magento website). It referres to the 'Website' in the Magento's "Website - Store - Store View" terminology / hierarchy. Settings in the top of the hierarchy are inherited down the path to every store view. With "[*] Use Website" we practically use the settings which are defined 1 level higher. To override such a setting in a store view, you have to uncheck the box.

 

 

3. Here is a great page with images that shows how to enable (a previously installed) language pack in Magento. For the store view, as well as for the admin area. It's for a french language pack, but of course the shown Magento settings work for any language pack you might have. If you are new to Mento you will like it:

 

http://imaginaerum.github.io/magento2-language-fr-fr/en.html