Showing results for 
Search instead for 
Did you mean: 

Configurable product not visible, only "Simple/Virtual" products.

Configurable product not visible, only "Simple/Virtual" products.



I'm having real issues using Magento 2.1 importer. I'm not sure if I'm missing a couple of screws, or the import process is completely illogical. I've been trying to import a .csv of products for over 36 hours straight, and being annoyed is an understatement. I would really appriciate some help.


I have a .csv with 2k configurable products. Of which, I have 4k simple products. I'm simply trying to import my products onto my store. I don't have any plugins, it's a fresh install with the following specs:


  • Ubuntu 14.04.1
  • Magento 2.1.0
  • 1GB Ram (I'm the only one using the box)
  • 20GB HDD Space
  • Root permissions and full access to the system config, not using shared hosting.


Okay, so I've managed to import 2 configurable products, and 6 simple products. When trying to upload my full .csv file I get a "General System Exception" which is very informative, there are also no error logs! Which helps a lot - however that is a matter for another day.


When I successfully import my 8 variants, I have 2 which are "Configurable" and 6 which are "Simple", I have also tried "Virtual" to see if it helps. This is what I see in "Products > Catalog". I have set prices which aren't $0 for each "Virtual" pro...


I have circled the "Not visible individually" and "Catalog, Search" in red for each product, as when I search my site, I can actually see the products labeled "Not visible individually", but I cannot see my configurable products. Am I doing something wrong here?


Here is what my .csv looks like, just incase I have made a mistake. I have removed the prices again, but they are a value above 0.


Every time I add a product to my site, via SSH I run "sudo php bin/magento indexer:reindex" just to make sure things have gone though.


So how do I make it so my "Configurable" products, show those that are "Virtual" or "Simple" (I have tried both) in a dropdown, instead of them being their own products in search results?


All products are in stock

All "Virtual" or "Simple" have a quantity of 10

All products are enabled

All products are a part of a category below root

Configurable products don't have a duplicate URL-Key (Do Simple/Virtual products need a URL key? I wouldn't have thought so)

All Simple/Virtual have a price set

All Simple/Virtual are set to not visible individually

All Configurable are visible in catalog and search results

The Correct Main Website, Store, View have all been set

The .csv is made in excel, but saved as CSV (MS-DOS) and encoding is "UTF-8-BOM" via Notepad++


I don't know what else to try, I would really appriciate some advice!