cancel
Showing results for 
Search instead for 
Did you mean: 

Configurable products not pairing with their simple counterparts

Configurable products not pairing with their simple counterparts

Hello,

 

I've imported my properly formatted .csv into magento 2.1.2, but the configurable products aren't pairing with their simple counterparts.

 

  • Magento 2 Developer Mode enabled
  • All products are enabled
  • All products have a quantity above 0, and all are in stock
  • Reindex once products have been added
  • Magento multistore disabled
  • Pack size (Configurable product attribute) set to "global", "enabled at storefront", "Dropdown", "filterable (with results)", "visible at storefront", "used in product listing"
  • My CSV is formatted correctly, using "configurable_variations" to list the simple products which will be paired with the configurable product.

Yet I'm still having no luck. When I navigate to a product on my frontend, my dropdown lists no products. In the admin panel, when I click on a configurable product and scroll down to "Configurations", nothing is listed.

 

What is the problem? There is no errors on import, nothing obvious in error logs, no idea what to do. M2 Is becoming a pain in the a*se to get going.

3 REPLIES

Re: Configurable products not pairing with their simple counterparts

Hi @straightseeds,

 

There are several issues reported on Github. I.e: https://github.com/magento/magento2/issues/7011

Maybe you have a similar case.

--
If you've found one of my answers useful, please give "Kudos" or "Accept as Solution"

Re: Configurable products not pairing with their simple counterparts

Hello @Damian Culotta,

 

Thanks for the links, I've just had a read through and it appears the issues are relating to virtual/simple products (this is happening to me too), but doesn't seem to affect the simple+configurable product relation and their appearance via frontend.

 

Please feel free to correct me if I have misunderstood.

Re: Configurable products not pairing with their simple counterparts

I'm not fully sure but I know that there are some issues with configurable products even on Magento 2.1.2.

I've just posted one of the latest issues on Guthub.

Right now I can't find one of the issues that Iv'e saw lately but if you look here https://github.com/magento/magento2/issues?utf8=%E2%9C%93&q=is%3Aissue%20is%3Aopen%20configurable you'll see some issues similar with yours.

 

Into the forums you'll find the same problem: https://community.magento.com/t5/Programming-Questions/Unable-to-link-existing-simple-products-to-co...

 

I'm trying to find one the issues (I found another one related https://github.com/magento/magento2/issues/6424 ).

What I'm trying to show you is that there is some kind of bug there and the community and the Magento Team are working on it.

 

--
If you've found one of my answers useful, please give "Kudos" or "Accept as Solution"