cancel
Showing results for 
Search instead for 
Did you mean: 

Installed language not applied

Installed language not applied

I installed this language package: https://packagist.org/packages/magento2translations/language_bg_bg with composer, but it isn't applied to the frontend. I've cleaned the cache, I can see the files in vendor.

 

In the backend I changed the language for my user to bg and some of the strings in backend are translated. In the frontend however everything is set to english. I've selected the language pack as the locale, so english shouldn't be shown in frontend.

 

Any ideas what I might be doing wrong?

1 REPLY

Re: Installed language not applied

Instead of adding your language pack to vendor directory - add language pack to app/i18n directory.

 

Below is the detailed instructions step to install Bulgarian(bg_BG) language.

 

  1. Download the Bulgarian (bg_BG) language pack from this link - https://github.com/denchev/magento2-bulgarian-language-pack
  2. Create app/i18n/denchdev/bg_bg/ directory and put all the downloaded language-pack files in this bg_bg directory.
  3. Now Upgrade installation using command - php bin/magento setup:upgrade
  4. Clear cache using command - php bin/magento cache:clean
  5. Deploy static content command - php bin/magento setup:static-content:deploy bg_BG
  6. Now to activate the language for frontend , logged in to admin panel then go to stores -> configuration -> general settings -> locale options -> select Bulgarian language from locale dropdown - Also Make sure you have selected  store view from storeview dropdown on the top of the settings screen.
  7. Click on save buttton and check on frontend side content will shows in bulgarian language.

 

For More Details refer this link - https://github.com/denchev/magento2-bulgarian-language-pack

 

Note : While doing this all make sure you are in developer mode - as magento 2.2.2 version you can not change locale while your in production mode.

if issue solved,Click Kudos & Accept as Solution