cancel
Showing results for 
Search instead for 
Did you mean: 

Logo URL always HTTPS instead of HTTP

Logo URL always HTTPS instead of HTTP

Hello there,

 

we are facing the problem that the uploaded logo (Settings->General->Design->Header) is always shown with HTTPS instead of HTTP.

This causes several browsers (like Safari Desktop/Mobile) to not display the logo because of mixed protocol/domains.

How can we set the logo url always to http when visiting the website with http?

 

We didn't changed any Base URL's. Use Secure URLs on Storefront and Admin is activated.

If I visit the website with HTTP, all pictures are shown with HTTP, exluding Logo

If I visit the website with HTTPS, all pictures are shown with HTTPS, including Logo.

 

(I'm using the porto theme.)

 

Hopefully you have any tips or suggestions. Thanks!

2 REPLIES

Re: Logo URL always HTTPS instead of HTTP

First remove your rule.

Then, as per this reference go to your admin area. Go to System > Configuration > Web > Secure and turn on the options "Use secure URLS in frontend" and "Use secure URLS in admin".

Links on your website should now all be https. You can use the following rule to redirect people that bookmarked the http-version of your site:

RewriteCond %{HTTPS} off RewriteRule ^ https://example.com%{REQUEST_URI} [R,L]

Change the R flag to R=301 after testing everything works as expected.

OpenSource Expert | OpenSource Technologies | www.opensourcetechnologies.com
Magento plugins released: http://www.opensourcetechnologies.com/product/product-category/magento-extensions

Re: Logo URL always HTTPS instead of HTTP

We don't want to always display every site as https.

Also I don't know what you mean with "First remove your rule". What rule?