Showing results for 
Search instead for 
Did you mean: 

Removed module is haunting me

Removed module is haunting me

I manually installed a module and then manually removed it.  Now I'm getting this error in the Magento exceptions log:


[2021-10-06 19:07:32] main.CRITICAL: Please upgrade your database: Run "bin/magento setup:upgrade" from the Magento root directory. Geissweb_Euvat data: current version - none, required version - 1.8.7 at /cache/vendor/magento/framework/Module/Plugin/DbStatusValidator.php:66)"} [] Geissweb_Euvat schema: current version - none, required version - 1.8.7


I'm also getting this error when I run bin/magento list in bash:

In ClassReader.php line 28:

Class Geissweb\Euvat\Console\Command\CleanVatNumbers does not exist


These are the steps I took to manually remove the module:

php bin/magento module:disable Geissweb_Euvat

Removed the module Geissweb_Euvat from app/etc/config.php

Droped new columns:

Droped new Table:

Removed the folder app/code/Geissweb
Removed the folder generated/code/Geissweb

Removed module configuration settings from core_config_data table

Removed module from setup_module table

Removed new attributes from eav_attribute table

Ran these in SSH:
php bin/magento setup:upgrade
php bin/magento setup:di:compile
php bin/magento setup:static-content:deploy
/usr/share/stratus/cli cache.all.clear


Any help is appreciated.  I've spent about a full day on this.



A better question might be: Where else is Magento getting module information from?  If all the standard areas are cleaned up, where is it even getting the name of the module from?




Re: Removed module is haunting me

Hello @SN_John 


If you did not install the module via composer, it won't work.
You can only disable it via bin/magento module:disable SP_Gridthumbs.

To remove the module, remove the folder SP/Gridthumbs, remove the record with module = 'SP_Gridthumbs' from the table setup_module and remove any other tables or records added by the install of the module.
Also, remove the line with SP_Gridthumbs from app/etc/config.php

If you get the solution then please, "Kudos" and "Accept as Solution" for Token of Appreciation

Re: Removed module is haunting me

Hi deep_popat,


Thanks for you reply. 

I'm confused by your statement:

If you did not install the module via composer, it won't work.

I did exactly what you said before posting here. I listed it all in my OP.  That's why I'm asking for help.

So, where is Magento even getting the information about the module name and version in that error message?


I'm going to reinstall and disable the module so I can move forward.  But I would really love some help understanding this problem so I can completely remove the module.



Re: Removed module is haunting me

I think I figured it out.  The solution is a subtle variation to the standard commands.


Sven, at Geissweb, was kind enough to answer my questions even after he had fully refunded me for the module, which I no longer needed.


I ran the following in developer mode:

php bin/magento module:disable Geissweb_Euvat --clear-static-content

php bin/magento setup:upgrade


The key was to run those commands prior to deleting the module files. 


Re: Removed module is haunting me

I spoke to soon. :/  After I deleted the module files the two errors returned.


These are such strange errors.