cancel
Showing results for 
Search instead for 
Did you mean: 

Applying theme breaks multistore catalog navigation

0 Kudos

Applying theme breaks multistore catalog navigation

Feature request from Ctucker9233, posted on GitHub May 23, 2016

Steps to reproduce

  1. Fresh install of Magento 2 from CPanel
  2. Create 2nd root category with subcategories
  3. Create 2nd website, store and store view Note: At this point I could visit my base url and see no categories (I didn't add and categories to the default root category) then go to my new url which didn't have styles applied to it and see my categories and subcategories.
  4. Apply magento blank theme to new store view

Expected result

New url has selected theme applied and catalog navigation shows categories with subcategories

Actual result

New url shows the default theme (luma) and catalog navigation does not appear (remember, no subcategories in the default root category)

6 Comments
New Member
Status changed to: Investigating
 
New Member

Comment from vil11, posted on GitHub May 24, 2016

Hi @Ctucker9233 !

Create 2nd website, store and store view

Have you configured multiple Websites with Apache or Nginx?

Apply magento blank theme to new store view

Have you flushed Magento cache after switching the Theme?

-- :sunny: D Vilchynskyi, M2 QA

New Member

Comment from Ctucker9233, posted on GitHub May 24, 2016

Configured with Apache and Magento cache completely flushed.

New Member

Comment from Ctucker9233, posted on GitHub May 27, 2016

Any thoughts on this issue? I was able to get it working simply by including the store name in the url and disabling the "route to base url" option. I'd prefer to set it up in the way the documentation says to so that nothing could possibly break in the future.

New Member

Comment from snohe, posted on GitHub Jun 13, 2016

Hi @Ctucker9233, thanks for reporting this. We have created internal ticket MAGETWO-53774 for updating our documentation.

New Member

Comment from Ctucker9233, posted on GitHub Jun 18, 2016

Thanks @snohe.