cancel
Showing results for 
Search instead for 
Did you mean: 

Rename confusing CategorySetup class name

0 Kudos

Rename confusing CategorySetup class name

Feature request from wojtekn, posted on GitHub Sep 21, 2015

There is a class \Magento\Catalog\Setup\CategorySetup which takes care of setup for catalog_product and catalog_category entities.

This name is confusing and better name would be CatalogSetup.

2 Comments
Not applicable

Comment from davidalger, posted on GitHub Nov 10, 2015

@wojtekn Would you like to submit a PR which effects the requested name change?

Not applicable

Comment from wojtekn, posted on GitHub Dec 01, 2015

@DavidAlger I could, however at this point it could introduce backward compatibility issue. Do you think it still could be fixed?

Also, I guess this would also need to be done in EE code. What is preferred procedure to achieve this for both CE and EE?