cancel
Showing results for 
Search instead for 
Did you mean: 

cloudflare / CDN issue - product grid does not load

0 Kudos

cloudflare / CDN issue - product grid does not load

Feature request from webkul, posted on GitHub Dec 14, 2015

cloudflare / CDN issue - product grid does not load - We are getting a very random issue whenever we supply the cloudlare on our server magento2 catalog grid does not load also throw an error related to backbone.js in admin product add at browser console.

19 Comments
New Member

Comment from guz-anton, posted on GitHub May 30, 2016

Hi @joebusby, It's great that such CDN configuration works for you. But Minify HTML and GZip compression not the same. Currently the issue with html content in Magento App. It's about Minify HTML. Html cannot be minifying properly by 3rd party app. Because html templates contain business logic in html comments, that should be trimmed in general approach.

GZip compression works great and does more performance boost than Minify HTML can.

New Member

Comment from bonsdawende, posted on GitHub Jul 20, 2016

Hello, I encountered the same problem. My catalog can't display when I use Cloudflare. I try the suggested solutions by nothing changes. As Webkul, when I used a static ip ex (xx.xx.xx.xx) it really work but not in subdomain. How do you resolve it ? I need your help.

New Member

Comment from guz-anton, posted on GitHub Jul 25, 2016

Hi @bonsdawende, please investigate your issue more deeply. Magento app should works well with Cloudflare CDN. Check your setting in Cloudflare account https://www.cloudflare.com/a/performance/google.com:
Speed > Auto Minify >[ ] HTML should be unchecked.

New Member

Comment from bonsdawende, posted on GitHub Jul 25, 2016

Hi @Anton, Thanks for you reply. I have already done it, but nothing changes. It doesn't work unfortunately.

​ Do you have other ways ?

2016-07-25 11:56 GMT+02:00 Anton Guz notifications@github.com:

Hi @bonsdawende https://github.com/bonsdawende, please investigate your issue more deeply. Magento app should works well with Cloudflare CDN. Check your setting in Cloudflare account https://www.cloudflare.com/a/performance/google.com:

Speed > Auto Minify >[ ] HTML should be unchecked.

— You are receiving this because you were mentioned. Reply to this email directly, view it on GitHub https://github.com/magento/magento2/issues/2697#issuecomment-234911293, or mute the thread https://github.com/notifications/unsubscribe-auth/AF_wjIfsvWPdU4R4BAEwnhCfT-xL5kZ8ks5qZIhlgaJpZM4G0r... .

New Member

Comment from nkalinovich, posted on GitHub Jul 27, 2016

Hi @bonsdawende , Have you flushed cache after applying this setting? Seems this this setting works for @suzannealdrich.

New Member

Comment from bonsdawende, posted on GitHub Jul 27, 2016

Hi, I did all (flush, reindex,...) but nothing changed unfortunately.

Ferdinand

2016-07-27 15:27 GMT+02:00 Nadia Kalinovich notifications@github.com:

Hi @bonsdawende https://github.com/bonsdawende , Have you flushed cache after applying this setting? Seems this this setting works for @suzannealdrich https://github.com/suzannealdrich.

— You are receiving this because you were mentioned. Reply to this email directly, view it on GitHub https://github.com/magento/magento2/issues/2697#issuecomment-235584164, or mute the thread https://github.com/notifications/unsubscribe-auth/AF_wjI2NGm_p4v2PYOpssQYbGrBY0kAUks5qZ1zFgaJpZM4G0r... .

-- Ferdinand KABORE

Engineer in Salesforce & Web

Port : 06 59 11 27 56

New Member

Comment from guz-anton, posted on GitHub Jul 28, 2016

@bonsdawende

when I used a static ip ex (xx.xx.xx.xx) it really work but not in subdomain.

So in both cases, Magento app works on the separate domain. But in the first case, it is a top level domain. Otherwise, it is a subdomain. Do I correctly understand? What is exact issue: does it completely broken or missed some parts of application?

New Member

Comment from bonsdawende, posted on GitHub Aug 01, 2016

Hi @guz-anton,

Yesterday, I guessed that the problem didn't due to Cloudflare but the problem is tied to Nginx.

When I changed my webserver by Apache, all works like a charm.

Have you tested Magento 2 with Nginx ? When you went to your catalog, could you see the differents products ?

Regular Visitor

Hi

 

I was facing the same issue and I fixed it by doing like this. 

I have used the Cdn url only for frontend files not for admin, how i did this is:

Store -> Configuration-> General ->Web

 

Under Base Url thre are 2 options:

Base Url 

and

Base Url (Secure)

 

I have defined my CDN for Base Url (secure) only and choose Secure URL in admin to No but for the frontend to yes and then after clearing the cache I got it fixed immediately.

 

Thanks