cancel
Showing results for 
Search instead for 
Did you mean: 

Centos 7 with Plesk and PHP

Centos 7 with Plesk and PHP

I am trying to enable Magento Data Migration Tool but keep getting error.

 

1) PHP Settings Check


2) PHP Extensions Check
missing PHP extensions

 

I have checked the php version on my plesk and i am running on 7.0.27 but when i go to SSH it shows with command "php -v"  

 

"PHP 5.4.16 (cli) (built: Nov 15 2017 16:33:54)
Copyright (c) 1997-2013 The PHP Group
Zend Engine v2.4.0, Copyright (c) 1998-2013 Zend Technologies
with the ionCube PHP Loader (enabled) + Intrusion Protection from ioncube24.com (unconfigured) v5.0.18, Copyright (c) 2002-2015, by ionCube Ltd"

 

Not sure how to fix this issue so i can get the Magento Data Migration Tool enabled and working. 

 

3 REPLIES

Re: Centos 7 with Plesk and PHP

Perhaps it's something you can ask your host to help out on?

 

PHP on the command line and web server are configured separately so it's easy to get in a situation where different versions are used for each. 

 

While you will want to ensure that both versions are consistent, the message "Missing PHP Extensions" sounds like a different problem. Does the error message detail which PHP extensions are missing, your message doesn't include them. 

 

There are a list of required PHP extensions on this page: http://devdocs.magento.com/guides/v2.2/install-gde/system-requirements-tech.html

 

You will need to make sure that they are all installed and configured. This may need the help of your host.

----
If you've found one of my answers useful, please give "Kudos" or "Accept as Solution" as appropriate. Thanks!

Re: Centos 7 with Plesk and PHP

As stated by @Tom Robertshaw you'll need to get your hosting provider to check and fix this. 

 

I believe that the Data Migration Tool is checking the PHP version and extension the same way as the command line which is why it's showing some PHP extensions missing. 

 

You'll need to get that corrected and make sure that both PHP versions and extensions are in sync to prevent any further problems down the road. 

James Lee | Moderator • Magento Master
See My Recommended Magento Hosting & Security Tips

Re: Centos 7 with Plesk and PHP

@firbest

 

On the server when you run the commands from command line, it by defaults run them using PHP 5.4 and that’s why you that message.

 

To run the command using PHP 7.0 you can run them like this:

 

/opt/plesk/php/7.0/bin/php -v

 

Instead of directly calling “php” it will be “/opt/plesk/php/7.0/bin/php

 

Here are few links for reference: https://talk.plesk.com/threads/how-to-remove-php-5-4.337677/

 

https://docs.plesk.com/en-US/onyx/administrator-guide/web-hosting/php-management/running-php-scripts...

 

For the extension you may be able to enable them from Plesk admin. If not then you need to connect with hosting provider if you have the support plan else you need to enable them by your own.

 

Thank you!

 

Problem solved? Please give 'Kudos' and accept 'Answer as Solution'.

 

 

Thanks,
Tarandeep
Magento 2 Certified Solution Specialist (x2). Follow me on Twitter