cancel
Showing results for 
Search instead for 
Did you mean: 

Store won't load, high number of 302 responses

Store won't load, high number of 302 responses

Hello Everyone and thank you in advance for any and all  thoughts and suggestions that you may have.

 

I recently installed Magento 2 CE on a Ubuntu 14 LAMP server with the following details:  Apache 2.4.18, MySQL 5.7.12. PHP 7.0.8-4, Magento 2.1.0.   Magento was installed in the /var/www/html/magento directory.

 

For hosting, I created a domain on go daddy and for the sake of discussion, I will refer to it as www.domain.com

 

When trying to access the site, the storefront will never load.  In looking at the apache access log, I see the following entry endlessly repeated:

 

X3.X7.X1.X09 - - [18/Jul/2016:09:20:35 -0400] "GET /magento/?SID=3ovdmsks81hfnd1ru22uq76eh3 HTTP/1.1" 302 647 "http://www.mydomain.com/magento/?SID=3ovdmsks81hfnd1ru22uq76eh3" "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:38.0) Gecko/20100101 Firefox/38.0

 

The browser will ultimately time out.

 

Here are the relevant captures/excerpts for the Virtual Host, and .htaccess file located in "/var/www/html/magento"

 

Virtual Host:

 

<VirtualHost *:80>
    ServerName www.domain.com/magento
    ServerAdmin webmaster@mydomain.com
    DocumentRoot /var/www/html/magento
        <Directory /var/www/html/magento/>
            Options Indexes FollowSymLinks MultiViews
            AllowOverride All
        </Directory>
    ErrorLog ${APACHE_LOG_DIR}/error.log
    CustomLog ${APACHE_LOG_DIR}/access.log  combined
</VirtualHost>

 

 .htaccess excerpts


############################################

## GoDaddy specific options
Options -MultiViews

 

############################################

##default index file


DirectoryIndex index.php


<IfModule mod_php5.c>


############################################

## adjust memory limit


php_value memory_limit 768M
php_value max_execution_time 18000


############################################

## disable automatic session start

## before autoload was initialized


php_flag session.auto_start off


###########################################

## disable user agent verification to not break multiple image upload


php_flag suhosin.session.cryptua off

</IfModule>

<IfModule mod_php7.c>


############################################

## adjust memory limit


php_value memory_limit 768M

php_value max_execution_time 18000


############################################

## disable automatic session start

## before autoload was initialized


php_flag session.auto_start off


###########################################

## disable user agent verification to not break multiple image upload


php_flag suhosin.session.cryptua off


</IfModule>


<IfModule mod_security.c>

###########################################

## disable POST processing to not break multiple image upload


SecFilterEngine Off

SecFilterScanPOST Off

</IfModule>


<IfModule mod_deflate.c>

 

############################################

## workaround for Apache 2.4.6 CentOS build when working via ProxyPassMatch with HHVM (or any other)

## Please, set it on virtual host configuration level


## SetEnvIf Authorization "(.*)" HTTP_AUTHORIZATION=$1

############################################


<IfModule mod_rewrite.c>


############################################

## enable rewrites


Options +FollowSymLinks

1 REPLY

Re: Store won't load, high number of 302 responses

You have the DocumentRoot set to /magento, and Magento is also looking to use /magento in the URL, which won't work. Either remove /magento from the DocumentRoot, or switch Magento to not use /magento in the URL.  Smiley Happy