cancel
Showing results for 
Search instead for 
Did you mean: 

magento with loadbalancer and 5 node web farm

magento with loadbalancer and 5 node web farm

Hi,

 

anyone have magento running in a HA/Load Balanced web farm?.

 

I'm using HAProxy with 5 web servers in my test system.. I have Prestashop running on these servers also, and have no issue with the LB using different servers, but with magento it only works on the original node and fails on the other nodes with server error 500.

The Database is hosted on its own DB server, magento installed/cloned to all web farm members

 

I know the LB is working fine as I have other apps running on it and along with Prestashop that is running on multiple nodes. I have sample of my setup... identical to below except just the 1 DB Server and 5 app nodes.

ha-diagram-animated.gif

Not sure why magento won't accept this config, any insight appreciated.

 

Thanks,

Johnny

3 REPLIES

Re: magento with loadbalancer and 5 node web farm

Hi @johnnyhandsome,

 

 


Since this has been posted several weeks ago, I would like to know if you were able to find the solution.


Please let us know.
Best regards.
Gabriel

If my answer was useful, please give "Kudos" to this post.
If my answer helps you to resolve the problem, click on "Accept as Solution".

Re: magento with loadbalancer and 5 node web farm

hello,

i haven't found a solution to this problem as of yet.

thanks,
Johnny

Re: magento with loadbalancer and 5 node web farm

Can you tell more about your stack, are you using Apache or Nginx? mod_php or PHP-fpm? 

Since you're getting error 500, can you grep full error from your log files? It should show us the main cause. 

 

If you're using Nginx with PHP-FPM, it could be that your nginx configuration file is not okay. Magento2 has recommended NGINX configuration which can be good starting point.

If this response was helpful to you, consider giving kudos to this post.
If this response solved your problem, click accept as solution to help others solve this issue