cancel
Showing results for 
Search instead for 
Did you mean: 

Locale in themes.json ignored

Locale in themes.json ignored

I am testing the compilation of the snowdog blank theme with Frontools.

 

However when I change the locale in my themes.json file it is ignored and only the en_US and pl_PL locales are created.

 

Am I doing something wrong ?

 

 

Below is my themes.json:

 

{
  "blank": {
    "src": "vendor/snowdog/theme-blank-sass",
    "dest": "pub/static/frontend/Snowdog/blank",
    "locale": ["en_US", "en_GB"],
    "ignore": [".test"]
  },
  "basic-child": {
    "src": "vendor/snowdog/theme-basic-child",
    "dest": "pub/static/frontend/Snowdog/basic-child",
    "locale": ["en_US", "en_GB"],
    "parent": "blank"
  },
  "child-with-locale-overwrites": {
    "src": "vendor/snowdog/theme-custom",
    "dest": "pub/static/frontend/Snowdog/child-with-locale-overwrites",
    "locale": ["en_US", "en_GB"],
    "localeOverwrites": true,
    "parent": "blank"
  },
  "all-possible-options": {
    "src": "vendor/snowdog/theme-all-possible-options",
    "dest": "pub/static/frontend/Snowdog/all-possible-options",
    "locale": ["en_US", "en_GB"],
    "localeOverwrites": true,
    "parent": "blank",
    "stylesDir": "web/css",
    "postcss": ["plugins.autoprefixer()"],
    "modules": {
      "Snowdog_Sample": "vendor/snowdog/module-sample"
    },
    "ignore": [
      "vendor/snowdog/module-sample/{docs,dist}/**",
      "*.xml"
    ]
  }
}

Thanks

 

1 REPLY

Re: Locale in themes.json ignored

I'm pretty sure you run `gulp setup` and now have a `dev/tools/frontools/config/themes.json` file, which has higher load priority than `vendor/snowdog/frontools/config/themes.json` which you are trying to modify.

 

PS. Remove unnecessary themes from the configuration. Sample configuration !== ready to use configuration.