cancel
Showing results for 
Search instead for 
Did you mean: 

gulp deploy give me locale not found

SOLVED

gulp deploy give me locale not found

 

 

After i run "gulp setup" from task sub folder its give me

 

 [08:49:46] Setup complete! Go to "/dev/tools/frontools/config/" directory and edit the configuration there.

 

and then i try to use gulp deploy and i get this error log:

 

PHP Fatal error: Uncaught Error: Class 'Locale' not found in /Users/refaelgold/PhpstormProjects/vagrant-magento/magento2ce/lib/internal/Magento/Framework/Locale/Bundle/DataBundle.php:64
Stack trace:
#0 /Users/refaelgold/PhpstormProjects/vagrant-magento/magento2ce/lib/internal/Magento/Framework/Locale/Bundle/DataBundle.php(28): Magento\Framework\Locale\Bundle\DataBundle->cleanLocale('en_US')
#1 /Users/refaelgold/PhpstormProjects/vagrant-magento/magento2ce/lib/internal/Magento/Framework/Setup/Lists.php(80): Magento\Framework\Locale\Bundle\DataBundle->get('en_US')
#2 /Users/refaelgold/PhpstormProjects/vagrant-magento/magento2ce/lib/internal/Magento/Framework/Validator/Locale.php(42): Magento\Framework\Setup\Lists->getLocaleList()
#3 /Users/refaelgold/PhpstormProjects/vagrant-magento/magento2ce/app/code/Magento/Developer/Console/Command/SourceThemeDeployCommand.php(144): Magento\Framework\Validator\Locale->isValid('en_US')
#4 /Users/refaelgold/PhpstormProjects/vagrant-magento/magento2ce/vendor/symfony/console/Symfony/Component/Co in /Users/refaelgold/PhpstormProjects/vagrant-magento/magento2ce/lib/internal/Magento/Framework/Locale/Bundle/DataBundle.php on line 64
[08:51:27] 'deploy' errored after 518 ms
[08:51:27] Error: Command failed: /Users/refaelgold/PhpstormProjects/vagrant-magento/magento2ce/bin/magento dev:source-theme:deploy --type=less --locale=en_US --area=adminhtml --theme=Magento/backend css/styles-old css/styles
PHP Fatal error: Uncaught Error: Class 'Locale' not found in /Users/refaelgold/PhpstormProjects/vagrant-magento/magento2ce/lib/internal/Magento/Framework/Locale/Bundle/DataBundle.php:64
Stack trace:
#0 /Users/refaelgold/PhpstormProjects/vagrant-magento/magento2ce/lib/internal/Magento/Framework/Locale/Bundle/DataBundle.php(28): Magento\Framework\Locale\Bundle\DataBundle->cleanLocale('en_US')
#1 /Users/refaelgold/PhpstormProjects/vagrant-magento/magento2ce/lib/internal/Magento/Framework/Setup/Lists.php(80): Magento\Framework\Locale\Bundle\DataBundle->get('en_US')
#2 /Users/refaelgold/PhpstormProjects/vagrant-magento/magento2ce/lib/internal/Magento/Framework/Validator/Locale.php(42): Magento\Framework\Setup\Lists->getLocaleList()
#3 /Users/refaelgold/PhpstormProjects/vagrant-magento/magento2ce/app/code/Magento/Developer/Console/Command/SourceThemeDeployCommand.php(144): Magento\Framework\Validator\Locale->isValid('en_US')
#4 /Users/refaelgold/PhpstormProjects/vagrant-magento/magento2ce/vendor/symfony/console/Symfony/Component/Co in /Users/refaelgold/PhpstormProjects/vagrant-magento/magento2ce/lib/internal/Magento/Framework/Locale/Bundle/DataBundle.php on line 64
at checkExecSyncError (child_process.js:486:13)
at execSync (child_process.js:526:13)
at theme.locale.forEach.locale (/Users/refaelgold/PhpstormProjects/vagrant-magento/magento2ce/dev/tools/frontools/task/deploy.js:19:9)
at Array.forEach (native)
at themes.forEach.name (/Users/refaelgold/PhpstormProjects/vagrant-magento/magento2ce/dev/tools/frontools/task/deploy.js:14:20)
at Array.forEach (native)
at Object.module.exports (/Users/refaelgold/PhpstormProjects/vagrant-magento/magento2ce/dev/tools/frontools/task/deploy.js:10:10)
at module.exports (/Users/refaelgold/PhpstormProjects/vagrant-magento/magento2ce/dev/tools/frontools/node_modules/orchestrator/lib/runTask.js:34:7)
at Gulp.Orchestrator._runTask (/Users/refaelgold/PhpstormProjects/vagrant-magento/magento2ce/dev/tools/frontools/node_modules/orchestrator/index.js:273:3)
at Gulp.Orchestrator._runStep (/Users/refaelgold/PhpstormProjects/vagrant-magento/magento2ce/dev/tools/frontools/node_modules/orchestrator/index.js:214:10)
refaelgold at refaels-iMac in ~/PhpstormProjects/vagrant-magento/magento2ce/dev/tools/frontools/task on develop*
$ 

 

 i use Magento ver. 2.2.0-dev so maybe its the problem or it may be something else . 

 

Waiting for response , 

 

Thanks,

Nir

 

5 REPLIES

Re: gulp deploy give me locale not found

It's PHP error, not related to tools itself.

- Check if they change a syntax of "magento dev:source-theme:deploy"

- Check your configuration "/dev/tools/frontools/config/themes.json"

- Read code of "task/deploy.js"

 

 

PHP Fatal error: Uncaught Error: Class 'Locale' not found in /Users/refaelgold/PhpstormProjects/vagrant-magento/magento2ce/lib/internal/Magento/Framework/Locale/Bundle/DataBundle.php:64

 

Re: gulp deploy give me locale not found

I will try and let you know

 

thanks

Re: gulp deploy give me locale not found

Databundle is a file new at magento 2.2-dev and not inside magento 2.1 

 

i will downgrade to lower version and test it again 

Re: gulp deploy give me locale not found

Hey , this is the json file 

https://gist.github.com/refaelgold/7b14768fdd4fb6f61d5185a8d49ea6d3

i change snowdog to gold on registration.php and theme.xml for rename the time

 

i still have this error after i did all you say

i must say - its a fresh magento installation of magento 2.1 stable 

 

 

PHP Fatal error:  Uncaught Error: Class 'Locale' not found in /Users/refaelgold/PhpstormProjects/magento2-vagrant-for-developers/magento2ce/lib/internal/Magento/Framework/Locale/Bundle/DataBundle.php:64
Stack trace:
#0 /Users/refaelgold/PhpstormProjects/magento2-vagrant-for-developers/magento2ce/lib/internal/Magento/Framework/Locale/Bundle/DataBundle.php(28): Magento\Framework\Locale\Bundle\DataBundle->cleanLocale('en_US')
#1 /Users/refaelgold/PhpstormProjects/magento2-vagrant-for-developers/magento2ce/lib/internal/Magento/Framework/Setup/Lists.php(80): Magento\Framework\Locale\Bundle\DataBundle->get('en_US')
#2 /Users/refaelgold/PhpstormProjects/magento2-vagrant-for-developers/magento2ce/lib/internal/Magento/Framework/Validator/Locale.php(42): Magento\Framework\Setup\Lists->getLocaleList()
#3 /Users/refaelgold/PhpstormProjects/magento2-vagrant-for-developers/magento2ce/app/code/Magento/Developer/Console/Command/SourceThemeDeployCommand.php(144): Magento\Framework\Validator\Locale->isValid('en_US')
#4 /Users/refaelgold/Phpstor in /Users/refaelgold/PhpstormProjects/magento2-vagrant-for-developers/magento2ce/lib/internal/Magento/Framework/Locale/Bundle/DataBundle.php on line 64

    at checkExecSyncError (child_process.js:465:13)
    at execSync (child_process.js:505:13)
    at /Users/refaelgold/PhpstormProjects/magento2-vagrant-for-developers/magento2ce/vendor/snowdog/frontools/task/deploy.js:19:9
    at Array.forEach (native)
    at /Users/refaelgold/PhpstormProjects/magento2-vagrant-for-developers/magento2ce/vendor/snowdog/frontools/task/deploy.js:14:20
    at Array.forEach (native)
    at Object.module.exports.themes.forEach.theme.locale.forEach.theme.locale.forEach (/Users/refaelgold/PhpstormProjects/magento2-vagrant-for-developers/magento2ce/vendor/snowdog/frontools/task/deploy.js:10:10)
    at module.exports (/Users/refaelgold/PhpstormProjects/magento2-vagrant-for-developers/magento2ce/vendor/snowdog/frontools/node_modules/gulp/node_modules/orchestrator/lib/runTask.js:34:7)
    at Gulp.Orchestrator._runTask (/Users/refaelgold/PhpstormProjects/magento2-vagrant-for-developers/magento2ce/vendor/snowdog/frontools/node_modules/gulp/node_modules/orchestrator/index.js:273:3)
    at Gulp.Orchestrator._runStep (/Users/refaelgold/PhpstormProjects/magento2-vagrant-for-developers/magento2ce/vendor/snowdog/frontools/node_modules/gulp/node_modules/orchestrator/index.js:214:10)

In Addition ..Grunt and Less file on blank theme and luma works as excepted

Re: gulp deploy give me locale not found

vagrant issue...

sorry