cancel
Showing results for 
Search instead for 
Did you mean: 

gulp setup give me a 'use strict' error at snowdog/frontools

SOLVED

gulp setup give me a 'use strict' error at snowdog/frontools

Hey, i use showdog/frontools and i get this error when i run "gulp setup" on config sub folder of the module 

 

 

[08:32:29] Working directory changed to ~/PhpstormProjects/vagrant-magento/magento2ce/dev/tools/frontools
/Users/refaelgold/PhpstormProjects/vagrant-magento/magento2ce/dev/tools/frontools/gulpfile.js:1
(function (exports, require, module, __filename, __dirname) { cd 'use strict';
^^^^^^^^^^^^
SyntaxError: Unexpected string
at Object.exports.runInThisContext (vm.js:53:16)
at Module._compile (module.js:513:28)
at Object.Module._extensions..js (module.js:550:10)
at Module.load (module.js:458:32)
at tryModuleLoad (module.js:417:12)
at Function.Module._load (module.js:409:3)
at Module.require (module.js:468:17)
at require (internal/module.js:20:19)
at Liftoff.handleArguments (/usr/local/lib/node_modules/gulp/bin/gulp.js:116:3)
at Liftoff.<anonymous> (/usr/local/lib/node_modules/gulp/node_modules/liftoff/index.js:198:16)
refaelgold at refaels-iMac in ~/PhpstormProjects/vagrant-magento/magento2ce/dev/tools/frontools/config on develop*

 

i cant init the project and Phpstorm console show me that gulpfile.js as a wrong typo.

 

how to solve it? 

thanks

7 REPLIES

Re: gulp setup give me a 'use strict' error at snowdog/frontools

Which version of node.js are you using?

 

If not v4 -> RTFM.

Re: gulp setup give me a 'use strict' error at snowdog/frontools

I use 6 

Re: gulp setup give me a 'use strict' error at snowdog/frontools

Wrong user:/

 

I use node 6 

Re: gulp setup give me a 'use strict' error at snowdog/frontools

This is refaelly not my day - 20 hours of development Smiley Frustrated

 

 

i install https://nodejs.org/en/ LTS  4.4.7

 

sorry about it:/ 

Thanks

Re: gulp setup give me a 'use strict' error at snowdog/frontools

Does it works? If yes, mark my answer as solution, for further readers.

Re: gulp setup give me a 'use strict' error at snowdog/frontools

Its work with node v6.2.2 when i get the success message at the second post. 

 

I still not finish the installation because i was on magento2.2-dev 

 

So you think its ok to use ndoe v6.2.2 if i get the success message?

Re: gulp setup give me a 'use strict' error at snowdog/frontools

I use to test them on v6, but got some weird issues. I found that many plugins developers just stick to support only LTS versions, b/c Node evolves too fast.