cancel
Showing results for 
Search instead for 
Did you mean: 

Magento extension installing issue

Highlighted

Magento extension installing issue

Hi everybody! I'm finally landed to Magento 2! Here my first issue:

I purchased an extension on Magento Marketplace, I got my public and private keys, then I went to 

System->Web Setup Wizard

then on

System configuration

then entered the public and private access key

then Saved

then on Extensions Manager: here I'm not able to find the extension to install

I log out and log in as admin, flushed the cache and got a new public and private key and repeted the previous steps.

Nothing happens!

 

The extension is Klevu.

Magento version is: 2.3.5-p1

 

Is there anyone so kind to help me?

Really really thanks!!!

15 REPLIES 15
Highlighted

Re: Magento extension installing issue

Hi @euroshop,

 

Can you please specify which module you are using from the Klevu vendor?

 

There must be some documentation related to your extension as well for installing the extension using composer way (like mentioned in the below link)

https://support.klevu.com/knowledgebase/integration-steps-for-magento-2/

 

You can use the same way for installation and setup.

 

Hope this helps you!

Problem Solved! Click Kudos & Accept as Solution!

Highlighted

Re: Magento extension installing issue

Hi @euroshop 

For install Kelyu extention, you should use composer. For example:

composer require klevu/module-search
php bin/magento setup:upgrade
php bin/magento setup:static-content:deploy

Or kindly refer below link for your issue:
https://support.klevu.com/knowledgebase/integration-steps-for-magento-2/

It may help you.

Problem Solved? Click on 'Kudos' & Accept as Solution!

Highlighted

Re: Magento extension installing issue

Dear @Bhanu Periwal as I'm really new to Magento 2, excuse me for the silly question:

how do I access to composer?

Do I have to access to the file composer.json?

Or is there another way? really thanks!

Highlighted

Re: Magento extension installing issue

Hi @euroshop ,

 

You can check the composer path using the command

which composer

it will return you composer installed path like below

/usr/bin/composer

OR

/usr/local/bin/composer

 

If you will not get any path then you need to install composer at your end using below link: https://getcomposer.org/doc/00-intro.md

 

After that, you are able to run the commands using the composer command in your SSH terminal.

 

Hope this helps you!

Problem Solved! Click Kudos & Accept as Solution!

Highlighted

Re: Magento extension installing issue

Dear @Nishu Jindal really thanks, my question is:

 

where do I have to enter the command?

In the file manager (I don't believe) or where?

 

really thanks, as you see I need very basic info! 

 

:-)

Highlighted

Re: Magento extension installing issue

Dear @Bhanu Periwal I executed the commands you suggested me and tha I found at the link you provided me.

that's what I got in answer. Can you help me?


[euroshop@us-wpl-c9-km160 ~]$ which composer
/opt/cpanel/composer/bin/composer
[euroshop@us-wpl-c9-km160 ~]$ composer require klevu/module search


[Composer\Downloader\TransportException]
The "https://repo.packagist.org/packages.json" file could not be downloaded: allow_url_fopen must be enabled in php.ini (https:// wra
pper is disabled in the server configuration by allow_url_fopen=0
failed to open stream: no suitable wrapper could be found)


require [--dev] [--prefer-source] [--prefer-dist] [--no-progress] [--no-suggest] [--no-update] [--no-scripts] [--update-no-dev] [--update-with-dependencies] [--update-with-all-dependencies] [--ignore-platform-reqs] [--prefer-stable] [--prefer-lowest] [--sort-packages] [-o|--optimize-autoloader] [-a|--classmap-authoritative] [--apcu-autoloader] [--] [<packages>]...

[euroshop@us-wpl-c9-km160 ~]$

Highlighted

Re: Magento extension installing issue

Hello @euroshop ,

 

You need to run these commands on the ssh panel (in your project root directory).

 

Please try running command like this

php -d allow_url_fopen=on /opt/cpanel/composer/bin/composer require klevu/module search 

Hope this helps you!

Problem Solved! Click Kudos & Accept as Solution!

Highlighted

Re: Magento extension installing issue

Here the response:

 

[euroshop@us-wpl-c9-km160 ~]$ allow_url_fopen=on /opt/cpanel/composer/bin/composer require klevu/module search


[Composer\Downloader\TransportException]
The "https://repo.packagist.org/packages.json" file could not be downloaded: allow_url_fopen must be enabled in php.ini (https:// wra
pper is disabled in the server configuration by allow_url_fopen=0
failed to open stream: no suitable wrapper could be found)


require [--dev] [--prefer-source] [--prefer-dist] [--no-progress] [--no-suggest] [--no-update] [--no-scripts] [--update-no-dev] [--update-with-dependencies] [--update-with-all-dependencies] [--ignore-platform-reqs] [--prefer-stable] [--prefer-lowest] [--sort-packages] [-o|--optimize-autoloader] [-a|--classmap-authoritative] [--apcu-autoloader] [--] [<packages>]...

[euroshop@us-wpl-c9-km160 ~]$ -d allow_url_fopen=on /opt/cpanel/composer/bin/composer require klevu/module search
bash: -d: command not found

Highlighted

Re: Magento extension installing issue

Hi @euroshop ,

 

Command is starting with php.. I hope you are running complete command.

 

php -d allow_url_fopen=on /opt/cpanel/composer/bin/composer require klevu/module search 

 

Thanks!