cancel
Showing results for 
Search instead for 
Did you mean: 

Reference to undeclared plugin

Reference to undeclared plugin

I've upgraded my site from v2.3.1 to v2.3.6 and I now get the error:

Reference to undeclared plugin with name 'priceIndexUpdater'

in my system.log.

I've found that in vendor\magento\module-inventory-catalog\etc\di.xml there is the line

    <plugin name="priceIndexUpdater" disabled="true"/>

Why is the plugin disabled when it is needed? Any ideas what will happen if I delete the line?

6 REPLIES 6

Re: Reference to undeclared plugin

Hello, @PedroKTFC 

 

I faced the same issue before!

 

Well, ... what I was seeing in debug.log and system.log [main.INFO: Reference to undeclared plugin with name 'priceIndexUpdater'] was probably a sort of a unconsistent OR approximate log dued to another exception occurred onto run-time flow of interceptors. I installed a module (MSP_Smtp) and inspecting the codebase. I found a piece of code to patch. Once I made the right modification, everything turned well again and the log disappeared. –

 

Thanks

Re: Reference to undeclared plugin

@PedroKTFCand @munesh_kumar1 did you happen to find a solution to this? I have come across the same problem after upgrading from 2.3.5p2 to 2.3.6, I'll post back if I get an answer myself to this problem!

Re: Reference to undeclared plugin

Hi @munesh_kumar1 , can you post what code you patched and how you patched it please? Also, how did you find it was that piece of code at fauly?

Thanks

Re: Reference to undeclared plugin

@munesh_kumar1 Can you give some more info?

 

JArda

 

Re: Reference to undeclared plugin

The plugin is no longer used, just disable it. There's an outstanding reference that seems to have been missed.

Re: Reference to undeclared plugin

Hello, how can I disable it? I have the same problem on Magento 2.3.6-p1

 

I copied vendor/magento/module-inventory-catalog/etc/di.xml

removed " <plugin name="priceIndexUpdater" disabled="true"/>" on line 39 and "<type name="Magento\InventoryIndexer\Indexer\SourceItem\SourceItemIndexer">
<plugin name="priceIndexUpdater" type="Magento\InventoryCatalog\Plugin\InventoryIndexer\Indexer\SourceItem\PriceIndexUpdater" sortOrder="20"/>
</type>" on line 23 - 25

to app/design/frontend/xx/xx/Magento_InventoryCatalog/etc

did setup:upgrade, setup:di:compile, c:f, c:c

 

But the system.log still gives this error every 30 sec or so. How can I disable it?

Thank you