cancel
Showing results for 
Search instead for 
Did you mean: 

cms static bloc do not show

cms static bloc do not show

Hi 

 

I have a multi store website. I added CMS block which display on anchor categories, main content top. 

The texts do appear on my main website EN but do not appear on the FR website. I created new blocks and I linked them to the FR website. I cleared all caches also.

 

Any idea why?

thanks!

10 REPLIES 10

Re: cms static bloc do not show

Hi @clemence_benharbon ,


Assign your new cms block to category 

 

1. edit the category & switch to desired store FR store.

2. Assign the cms block in the Add Cms block Section.

3. also confirm your cms block must have assigned to FR store by editing the cms block. 

 

After all the changes, clear the cache

 

Hope this helps you! 
Problem Solved! Click Kudos & Accept as Solution! 

Re: cms static bloc do not show

Hi

 

@Nishu Jindal thanks I tried but it still doesn't show up

I attached you what I did.

 

Am I missing something?

 

 

a.pngPeintures-ID-152-Categories-Inventory-Catalog-Magento-Admin.png

Re: cms static bloc do not show

@clemence_benharbon 

 

Can you share your screenshots on some server.

 

Thanks!

Re: cms static bloc do not show

Re: cms static bloc do not show

Hi @clemence_benharbon,


In the video you are showing the widget not the cms block.

 

Just check by editing Cms block in 

content > blocks that block is assigned to FR store or not.

 

Hope this helps you! 
Problem Solved! Click Kudos & Accept as Solution!

Re: cms static bloc do not show

Hi @Nishu Jindal 

 

It is well assigned to the store as you can see here: https://www.awesomescreenshot.com/video/1968958?key=aae2007f724fdac537cc1bdec18b539d

 

but it still doesn't show up unfortunately


@Nishu Jindal wrote:

Hi @clemence_benharbon,


In the video you are showing the widget not the cms block.

 

Just check by editing Cms block in 

content > blocks that block is assigned to FR store or not.

 

Hope this helps you! 
Problem Solved! Click Kudos & Accept as Solution!


 

Re: cms static bloc do not show

Hi @clemence_benharbon ,

 

Just want to be check, you are using the same Theme "Custom Pearl Theme for Magento 2" for the FR store as well. 

 

Please check and confirm.

 

 

Hope this helps you!

Problem Solved! Click Kudos & Accept as Solution!

Re: cms static bloc do not show

Hi @Nishu Jindal 

sorry for the late answer, I didn't receive a notification Smiley Happy

 

I actually don't think so. If this is the issue, how should I proceed then?

 

thanks a lot!

Re: cms static bloc do not show

HI @clemence_benharbon ,

 

In that case, you need to delete this widget and create the new one with the required theme which works for your FR store.

 

Hope this helps you!

Problem Solved! Click Kudos & Accept as Solution!