cancel
Showing results for 
Search instead for 
Did you mean: 

Code Migration Tool installation error : your PHP version (7.1.9) does not satisfy that requirement

Highlighted

Code Migration Tool installation error : your PHP version (7.1.9) does not satisfy that requirement

Hello

 

 

I am using code migration tool (https://github.com/magento/code-migration#installation)

but running "composer install" gives an error and does not install it at all.

 

Do you have suggestions?

 

The error is

Warning: The lock file is not up to date with the latest changes in composer.json. You may be getting outdated dependencies. Run update to update them.
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - Installation request for magento/framework 100.0.12 -> satisfiable by magento/framework[100.0.12].
    - magento/framework 100.0.12 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.1.9) does not satisfy that requirement.

The composer.json :

{
    "name": "magento/migration",
    "description": "Tools for migrating Magento 1 extensions to Magento 2",
    "type": "project",
    "version": "0.0.1-alpha",
    "license": [
        "OSL-3.0",
        "AFL-3.0"
    ],
    "repositories": {
        "magento": {
            "type": "composer",
            "url": "https://repo.magento.com"
        },
        "pear": {
            "type": "pear",
            "url": "https://pear.php.net"
        }
    },
    "require": {
        "php": "~5.5.0|~5.6.0|~7.0.0|~7.1.0",
        "symfony/console": "2.7.4",
        "monolog/monolog": "1.17.1",
        "zendframework/zend-stdlib": "2.5.0",
        "zendframework/zend-code": "2.5.0",
        "magento/zendframework1": "1.12.13",
        "magento/framework": "100.0.*",
        "pear/xml_serializer": "*",
        "zendframework/zend-http": "2.5.0"
    },
    "require-dev": {
        "phpunit/phpunit": "4.1.0",
        "sebastian/phpcpd": "2.0.4",
        "squizlabs/php_codesniffer": "1.5.3",
        "phpmd/phpmd": "@stable",
        "pdepend/pdepend": "2.5.0",
        "sjparkinson/static-review": "~4.1",
        "fabpot/php-cs-fixer": "~1.2"
    },
    "config": {
        "use-include-path": true,
        "secure-http": false
    },
    "autoload": {
        "psr-4": {
            "Magento\\Migration\\": "src/Magento/Migration/"
        }
    },
    "autoload-dev": {
        "psr-4": {
            "Magento\\Migration\\": "tests/unit/Magento/Migration/",
            "Magento\\Sniffs\\": "dev/tests/static/framework/Magento/Sniffs/",
            "Magento\\TestFramework\\Inspection\\": "dev/tests/static/framework/Magento/TestFramework/Inspection/",
            "Magento\\TestFramework\\Utility\\": "dev/tests/static/framework/Magento/TestFramework/Utility/"
        }
    },
    "minimum-stability": "alpha",
    "prefer-stable": true
}
1 REPLY

Re: Code Migration Tool installation error : your PHP version (7.1.9) does not satisfy that require

Hi  @tvgarden,

 

Maybe you could report this at https://github.com/magento/code-migration/issues

I guess there is a conflict or wrong version number on composer dependencies with Magento/ZendFramework or Magento/Frameowork.

--
If you've found one of my answers useful, please give "Kudos" or "Accept as Solution"