Showing results for 
Search instead for 
Did you mean: 

Customizable Option not changing price

Customizable Option not changing price



I've got a strange problem.


I have configurable items that also have customizable options to choose from.

Currently I've added these to few of my products. However I noticed a problem.


With product A both configurations and options work as intended.

With product B everything does change the price on the product page but when product is added to cart price excludes customizable options. 


I added everything the same way. Configurable products where all imported via importer using csv files, so there is no way some products have different settings.


Any idea what is wrong? I tried reindexing, clearing cache and so on but those didn't have any effect.


Re: Customizable Option not changing price

Hello @michallenc87d8 


Please do re-index after import the products by CSV file. so the product price will update perfectly.


If you get the solution then please, "Kudos" and "Accept as Solution" for Token of Appreciation

Re: Customizable Option not changing price

@dipmegpro  Hi, thanks for reply.


Well the thing is, I already did reindex multiple times.


The configurable products work just fine. U can choose whichever configuration you want and it will choose appropriate single product.


Its the "customizable options" that do not work. When adding extras to the chosen product they won't transfer to cart and checkout later on.



Tested few more things and file upload (for customers to upload their designs) is working only for the product A. Also it seems that simple product are working as expected. Which makes the fact that ONE configurable product works even stranger.

I have changed the templates from porto child to default porto and to luma without any effect. It still does not work properly. Also I've tried adding different pictures to configurations on product B as that was the only difference between them. This also didn't do anything. Tested on mobile and it's not working, as expected.


How can I troubleshoot this? I have run out of ideas at this point.