cancel
Showing results for 
Search instead for 
Did you mean: 

Error conflicting component dependencies while updating or install new extenstion

Error conflicting component dependencies while updating or install new extenstion

Dear, I try to install one new extension and in the Check Readiness I saw this error:

 

Check Component Dependency
We found conflicting component dependencies. Hide detail

Command "update" failed: PHP temp directory (/tmp) does not exist or is not writable to Composer. Set sys_temp_dir in your php.ini
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

Problem 1
- Installation request for magento/product-community-edition 2.2 -> satisfiable by magento/product-community-edition[2.2.0].
- magento/product-community-edition 2.2.0 requires composer/composer 1.4.1 -> satisfiable by composer/composer[1.4.1] but these conflict with your requirements or minimum-stability.


For additional assistance, see component dependency help .

How to fix this issue? I tried with SSH composer update, but the same error appear there.

2 REPLIES

Re: Error conflicting component dependencies while updating or install new extenstion

Hi @kostianev,


Can you check if the user you're using is the same user has created that directory?

It seems to be a permission issue.

--
If you've found one of my answers useful, please give "Kudos" or "Accept as Solution"

Re: Error conflicting component dependencies while updating or install new extenstion

Hi, I am using the same username in administration and the root user in SSH. It`s seem that the username is this.