cancel
Showing results for 
Search instead for 
Did you mean: 

Magento 2.2.4 EE Menu is not appear on home page

Magento 2.2.4 EE Menu is not appear on home page

In Magento 2.2.4 Enterprise edition menu not appear on only home page.

 

megamenu.png

 

 

 

But on other all pages it's appear.login-menu.png

 

 

 

I was checked and found that JS is not showing in inspect element on home page, so reason for this menu is not displaying.

in inspect element on home page showing like this 

<esi:include src="http://127.0.0.1/ab-ee/page_cache/block/esi/blocks/%5B%22catalog.topnav%22%5D/handles/WyJkZWZhdWx0IiwiY21zX2luZGV4X2luZGV4IiwiY21zX3BhZ2VfdmlldyJd/"></esi:include>

Actually problem is related to Varnish Cache if i disable Varnish Cache from Store -> Configuration -> Advanced -> System -> Full page cache -> Caching Application Set to Varnish Cache then menu is not displaying if i set to 'Built-in cache' then it's working fine.

Can anybody know it is necessary to select Varnish Cache and what happens if we not select Varnish Cache?

 

Any help would be appreciated. Thanks.

2 REPLIES

Re: Magento 2.2.4 EE Menu is not appear on home page

Hi @Patel_Chirag,

 

If you're using the default Luma theme without custom modules that shouldn't happen.

But maybe there ir a customization that is not working nicely with Varnish.

Removing Varnish can be translated as some possible imapct on performance, speed (or the feeling of speed).

Varnish is part of the recommended/should be always active on production stack of software for Magento2: https://devdocs.magento.com/guides/v2.2/install-gde/system-requirements-tech.html

 

If you have doubts about why or when you should use Varnish with your Magento Commerce implementation maybe you could ask to your System Integrator about the possible effects of not using it with the project.

--
If you've found one of my answers useful, please give "Kudos" or "Accept as Solution"

Re: Magento 2.2.4 EE Menu is not appear on home page

@Damian Culotta Thanks for giving your valuable time, 

 

I was checked twice with install new fresh magento & and also cross check with different system, but issue is stil showing.

 

You can also generate this issue with following step.

Store -> Configuration -> Advanced -> System -> Full page cache -> Caching Application Set to Varnish Cache

 

Then check you also facing this issue.