cancel
Showing results for 
Search instead for 
Did you mean: 

Magento 2.4.2 not showing products in category pages after update, here the log

Magento 2.4.2 not showing products in category pages after update, here the log

Magento 2.4.2 not showing products in category pages after update, this is what I get into the var\log\exception.log:

main.CRITICAL: Class Magento\Catalog\Helper\HelperNew does not exist {"exception":"[object] (ReflectionException(code: -1): Class Magento\\Catalog\\Helper\\HelperNew does not exist at /home/customer/www/mywebsitename.net/public_html/vendor/magento/framework/Code/Reader/ClassReader.php:24)"} []
main.CRITICAL: Front controller reached 100 router match iterations {"report_id":"0dded4d007695cad0a95bb4a073213cfb9107bfa9c94c708356e32e8568d8cd5","exception":"[object] (LogicException(code: 0): Front controller reached 100 router match iterations at /home/customer/www/mywebsitename.net/public_html/vendor/magento/framework/App/FrontController.php:133)"} []

I have already tried to upgrade, compile, reindex, clear and everything from putty as I said here Magento 2.4.2 not showing products in category pages after version update , but nothing, what about the errors I just posted, any help with that?

3 REPLIES 3

Re: Magento 2.4.2 not showing products in category pages after update, here the log

Please try to check that your Elasticsearch is working or not
for Magento 2.4 versions Elasticsearch is compulsory.

Re: Magento 2.4.2 not showing products in category pages after update, here the log

I changed the Store View from All Store Views to the store in question, selected the category with the problem, and noticed that the category settings were not selected to use the default value.
Selecting the options to use default value works.
Just double-check on the store view.

If issue solved, Click Kudos & Accept as Solution.
LitCommerce - The Most Simple & Affordable Multi-channel Selling Tool

Re: Magento 2.4.2 not showing products in category pages after update, here the log

I had the same problem you described, tried the same steps you outlined, tracked down the same collection query. Ultimately the cause was a product attribute added by a third-party extension, said attribute was improperly configured.

MyGiftCardSite.com