cancel
Showing results for 
Search instead for 
Did you mean: 

beginner friendly SSH extension installation info

beginner friendly SSH extension installation info

I'm pretty new to Magento & am working on my first site in Magento 2 now. I've built other sites in Joomla, Shopify, Weebly, etc. Thus far I'm finding Magento 2 to be the most user friendly of them all, but I haven't done anything before via SSH so am running into some issues with installing extensions.

 

I've done a bit of my own research so far, and while the Magento & extension documentation are very helpful they're not that beginner friendly. Are there any good resources to teach someone who's totally new to using SSH to install extensions to do so?

2 REPLIES 2

Re: beginner friendly SSH extension installation info

Hello @mainetopmi65d1 

 

Please refer to https://meetanshi.com/blog/install-magento-2-extension/ for your requirements.

 

I hope it helps.

Problem solved? Click Kudos and "Accept as Solution"

Re: beginner friendly SSH extension installation info

Thanks Sanjay, I actually came across your site when trying to uninstall a bad extension, since there was no support from the developer. I got some odd composer errors but was able to successfully uninstall the extension. I'm not sure if the errors I got were normal issues or that there's something wrong with composer. Couldn't have done it without your site. 

 

I'm running into 2 issues with extension installation. After I get the zip file uploaded, how were do I go to figure out what to enter to unzip it? Each time I've done this its wound up being something different than just the name of the zip file itself.

 

The second is related to actually unzipping the file itself. How do I know what command to enter to unzip? Or is it just trial & error. This is what worked for the first 2 extensions I installed (where=is the name of the zip file with no space after the /): 

unzip -d app/code/ -----

 

Just yesterday I installed a new extension that just needed me to enter "unzip" then the name of the zip file.

 

This was what I think was a composer issue. Does this mean something is wrong with composer or that it didn't like the uninstall of the extension? To the best of my knowledge the extension is gone (not visible on the back end of my site).

 

The "magento/magento-composer-installer" plugin was skipped because it requires a Plugin API version ("^1.0") that does not match your Composer installation ("2.0.0"). You may need to run composer update with the "--no-plugins" option.

The "dealerdirect/phpcodesniffer-composer-installer" plugin was skipped because it requires a Plugin API version ("^1.0") that does not match your Composer installation ("2.0.0"). You may need to run composer update with the "--no-plugins" option.

The "magento/inventory-composer-installer" plugin was skipped because it requires a Plugin API version ("^1.1") that does not match your Composer installation ("2.0.0"). You may need to run composer update with the "--no-plugins" option.

The "laminas/laminas-dependency-plugin" plugin was skipped because it requires a Plugin API version ("^1.1") that does not match your Composer installation ("2.0.0"). You may need to run composer update with the "--no-plugins" option.

The "magento/composer-root-update-plugin" plugin was skipped because it requires a Plugin API version ("^1.0") that does not match your Composer installation ("2.0.0"). You may need to run composer update with the "--no-plugins" option.

eyemagine/hubspotrepository is not required in your composer.json and has not been removed

./composer.json has been updated

The "magento/magento-composer-installer" plugin was skipped because it requires a Plugin API version ("^1.0") that does not match your Composer installation ("2.0.0"). You may need to run composer update with the "--no-plugins" option.

The "dealerdirect/phpcodesniffer-composer-installer" plugin was skipped because it requires a Plugin API version ("^1.0") that does not match your Composer installation ("2.0.0"). You may need to run composer update with the "--no-plugins" option.

The "magento/inventory-composer-installer" plugin was skipped because it requires a Plugin API version ("^1.1") that does not match your Composer installation ("2.0.0"). You may need to run composer update with the "--no-plugins" option.

The "laminas/laminas-dependency-plugin" plugin was skipped because it requires a Plugin API version ("^1.1") that does not match your Composer installation ("2.0.0"). You may need to run composer update with the "--no-plugins" option.

The "magento/composer-root-update-plugin" plugin was skipped because it requires a Plugin API version ("^1.0") that does not match your Composer installation ("2.0.0"). You may need to run composer update with the "--no-plugins" option.

Running composer update eyemagine/hubspotrepository

Loading composer repositories with package information

Package "eyemagine/hubspotrepository" listed for update is not locked.