cancel
Showing results for 
Search instead for 
Did you mean: 

soap module length??

soap module length??

hi guys

 

i'm trying to use the following modules and and just trying to login

 

integrationAdminTokenServiceV1,

storeStoreRepositoryV1,

customerCustomerRepositoryV1,

salesOrderRepositoryV1,salesOrderManagementV1,

salesInvoiceRepositoryV1,

salesInvoiceCommentRepositoryV1,

salesCreditmemoRepositoryV1,

salesCreditmemoCommentRepositoryV1,

catalogInventoryStockRegistryV1,

catalogProductRepositoryV1

 

 

<?xml version="1.0"?>
<s:Envelope xmlns:s="http://www.w3.org/2003/05/soap-envelope">
  <s:Body xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">
    <integrationAdminTokenServiceV1CreateAdminAccessTokenRequest xmlns="http://localhost:8085/magento2/soap/default?services=integrationAdminTokenServiceV1%2CstoreStoreRepositoryV1%2CcustomerCustomerRepositoryV1%2CsalesOrderRepositoryV1%2CsalesOrderManagementV1%2CsalesInvoiceRepositoryV1%2CsalesInvoiceCommentRepositoryV1%2CsalesCreditmemoRepositoryV1%2CsalesCreditmemoCommentRepositoryV1%2CcatalogInventoryStockRegistryV1%2CcatalogProductRepositoryV1">
      <username xmlns="">some-user</username>
      <password xmlns="">pw@1234</password>
    </integrationAdminTokenServiceV1CreateAdminAccessTokenRequest>
  </s:Body>
</s:Envelope>

 

this is the return

 

 

<?xml version="1.0" encoding="UTF-8"?>
<SOAP-ENV:Envelope xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/">
  <SOAP-ENV:Body>
    <SOAP-ENV:Fault>
      <faultcode>WSDL</faultcode>
      <faultstring>SOAP-ERROR: Parsing WSDL: Couldn't load from 'http://localhost:8085/magento2/soap/default?services=integrationAdminTokenServiceV1%2CstoreStoreRepositoryV1%2CcustomerCustomerRepositoryV1%2CsalesOrderRepositoryV1%2CsalesOrderManagementV1%2CsalesInvoiceRepositoryV1%2CsalesInvoiceCommentRepositoryV1%2CsalesCreditmemoRepositoryV1%2CsalesCreditmemoCommentRepositoryV1%2CcatalogInventoryStockRegistryV1%2CcatalogProductRepositoryV1&amp;wsdl=1' : Extra content at the end of the document
</faultstring>
    </SOAP-ENV:Fault>
  </SOAP-ENV:Body>
</SOAP-ENV:Envelope>

 

but when i take 1 of the modules out say... catalogProductRepositoryV1 it works and i could get a token

 

but as soon as i have this one or anyother one on the url it errors, any ideas

 

 

2 REPLIES

Re: soap module length??

How to fix the «Extra content at the end of the document» failure for the SOAP responses? https://mage2.pro/t/1098

Re: soap module length??

still not quite sure what the fix is,

 

my POST does not contain 

&amp;wsdl=1

 

but the response when it error does... so unsure why this is