cancel
Showing results for 
Search instead for 
Did you mean: 

2.1.6 - Cache folder in media isn't created

SOLVED

2.1.6 - Cache folder in media isn't created

Hi !

Since I migrated my website (Magento 2.1.6) to a VPS and flushed cache, product images can't display.

I tried to re-deploy static files, delete caches, launch catalog:images:resize (with patch MAGETWO-67805), change permissions to 777, delete/reupdate htaccess in /media/, nothing happens and all product images are still 404.

I saw that the cache/f0xxxxxxxxxxx folders aren't created, even with permissions 777 to all or 644/files and 755/folders.

The only thing I suppose at the moment is a problem with the owner of the Magento folder. As I'm on a VPS, my ftp user is in a specific group and I don't have the rights to change the owner to www-data.

Is that a permissions problem or completely another thing ? Why Magento needs the www-data group ? Is there another solution ?

 

Weyy

1 REPLY

Re: 2.1.6 - Cache folder in media isn't created

After trying to update to Magento 2.1.7, I found out that Composer wasn't installed on the VPS so I installed it and upgraded Magento. Images are now shown. Problem solved !