cancel
Showing results for 
Search instead for 
Did you mean: 

2.1.7 and 2.2.3

SOLVED

2.1.7 and 2.2.3

Hi

 

Can anybody tell me how much difference there is between 2.1.7 and 2.2.3 from the point of view of appiying templates, for instance would or should a template for 2.1.7 work on 2.2.3. Hope this is the right place to pose this question

 

Cheers

 

Neil

** Dell Optiplex 9010, Intel Core I5, 16GB Memory, Centos 7.4 **
** PHP 7.1.16, MariaDB 10.1.11 **
6 REPLIES

Re: 2.1.7 and 2.2.3

Hello @CCaway

 

It depends how you created the template.

 

you can apply a template for latest Magento and check log file regarding error.

 

Hope it will help you.

Re: 2.1.7 and 2.2.3

Hi @CCaway

 

Looking at the release notes of magento 2.2.3 - seems like it doesn't have more changes on layout level.

 

but fewer modules/functionality is added with the base , so for that specific functionality modules layouts and other xml templates is also changed/added aside with few methods are also depreciated with newer version 2.2.3

 

Coming back to the main point - you need to at least installed your 2.1.7 version theme on magento 2.2.3 version and check whether its giving any major error which stops executing of website or it is working as it is.

 

because if theme developer haven't use any depreciated method in it then might be that theme will worked on newer version as well. so its all about try on basis.

 

Just sharing reference link of releast notes - http://devdocs.magento.com/guides/v2.2/release-notes/ReleaseNotes2.2.3CE.html

 

Note : Before doing anything/trying new i always suggest take a backup of existing files and db as well , so if needed we can revert back it for the same

 

if issue solved,Click Kudos & Accept as Solution

Re: 2.1.7 and 2.2.3

 

@ManthanDave and @Sunil Patel

Thanks for the information guys

 

I was quoted a substantual amount of money to upgrade a template from 2.1.7 to 2.2.3, the reason was it would need to be totally re-written. Scary stuff when you think of 2.3 in the future and PHP 7.2 going forward

 

Thanks again 

 

Cheers, Neil

 

  

** Dell Optiplex 9010, Intel Core I5, 16GB Memory, Centos 7.4 **
** PHP 7.1.16, MariaDB 10.1.11 **

Re: 2.1.7 and 2.2.3

Hi @CCaway (Neil)

 

I understand , but as i mention if current theme have used depreciated method then and then its stop working on 2.2.3 version.

 

But still to make it working on newer version it will not required substantual amount , as theme is already created so we just need to make it compatible with the newer version of Magento.

 

Regarding Magento 2.3 yes that is correct on that time might be few issue is occur ,as you said Magento 2 going to adapt php 7.2 version so.

 

Hope it helps Smiley Happy

if issue solved,Click Kudos & Accept as Solution

Re: 2.1.7 and 2.2.3

@ManthanDave


Hi Manthan

 

That was my thoughts also with the conversion from 2.1 to 2.2, it really should  not require a rewrite as as was suggested to me by the company selling it. Anyway decided not to go with their template and write one of my own.

 

Cheers. Neil

** Dell Optiplex 9010, Intel Core I5, 16GB Memory, Centos 7.4 **
** PHP 7.1.16, MariaDB 10.1.11 **

Re: 2.1.7 and 2.2.3

Hi  @CCaway  (Neil)

Glad to know that you have decided to go with the custom template ..

as when we are using custom template , things are always on our hand, even though new version of the application is released or we want to update using code level as well ..

so good decision you have taken ..

thanks for sharing Smiley Happy

if issue solved,Click Kudos & Accept as Solution