cancel
Showing results for 
Search instead for 
Did you mean: 

Admin Panel timout

SOLVED

Admin Panel timout

The Admin Panel is driving me nuts. I don't want to have to continually sign back in. Every time I'm prompted to sign in I have to navigate back to where I was working to pick up where I left off. It's frustrating, time consuming, and increases the risk of making errors or missing something.

 

I've tried a number of different values for Admin Session Lifetime (seconds), but it's never honored. The timeout is just too short. How do I get Magento to honor the session timeout?

3 REPLIES

Re: Admin Panel timout

It might be that your PHP session timeout values are set too low. There are two settings that you can try to adjust:

 

session.cookie_lifetime
session.gc_maxlifetime

Typically you want to set this to the same value (or higher) than what you have configured in the admin panel. If you have access to the server's php.ini file you can edit the settings directly. On a shared host you can try to override the values in your .htaccess like this:

 

php_value session.cookie_lifetime 1800
php_value session.gc_maxlifetime 1800

The above will set the session lifetime to 1800 seconds (30 minutes). Adjust as needed.

Sindre M, CEO & Founder
ProperHost.com - The Magento Hosting Experts

Re: Admin Panel timout

I found two files;

./php5/apache2/php.ini
./php5/cli/php.ini

 

I changed session.gc_maxlifetime on both and it looks like that's fixed it. Thank you so much. You've saved me no end of frustration.

Re: Admin Panel timout

Great! Glad I could help.

Sindre M, CEO & Founder
ProperHost.com - The Magento Hosting Experts