Showing results for 
Search instead for 
Did you mean: 

Attribute groups missing when creating new products

Attribute groups missing when creating new products



I'm having some issues with product attributes. After migrating product data from an existing 1.8  installation to our new 2.1.5 CE setup I'm having problems with product attributes. 


I have set up an attribute_set called Clothes which has an attribute group called price. It has an attribute_set_id of 26.


However when I try to create a new product and changes the attribute _set_id to Clothes (set id 26) the price group doesn't show up and the meta information group has the wrong name.



I have tried to query the database correctly and it looks correct.

select * from eav_attribute_group where attribute_set_id = 26;


select b.* from eav_entity_attribute a, eav_attribute b where a.attribute_id = b.attribute_id and a.attribute_set_id  = 26 and a.attribute_group_id = 164


I'm really struggling to see where the problem is. It really looks like a caching or indexing issue to me but I have tried reindexing and clearing cache multiple times and it makes no difference.


Any ideas?