cancel
Showing results for 
Search instead for 
Did you mean: 

Backend WYSIWYG editor shows html code by default

SOLVED

Backend WYSIWYG editor shows html code by default

Hi guys,

 

I am using Magento 2 Community edition.

 

I have created some attributes, which use WYSIWYG editor. 

 

My problem is that these attributes are showing html code by default on the product edit page when I login into the admin backend. 

 

How can I show the formatted content by default on the admin panel?

 

Thank you guys,

Tom

 

 

5 REPLIES

Re: Backend WYSIWYG editor shows html code by default

Hi @Uurtsaikh2017

 

First so you have created custom attribute of TextArea ? as WYSIWYG is only available for "Text Area" type attributes.

 

Also can you please confirm that  WYSIWYG button is showing on the product edit page in your custom attribute ? if possible shared a screenshot with us - so its helps us to troubleshoot the issue !

 
if issue solved,Click Kudos & Accept as Solution

Re: Backend WYSIWYG editor shows html code by default

Hi @ManthanDave,

 

Thank you for your quick reply.

 

Sure. You exactly understood my situation.

 

I am sending screenshots that you can see.

 

Thank you so much for your help.

It has been a big issue for us.

 

Tomattribute creation page.JPGProduct Edit page.JPG

 

 

Re: Backend WYSIWYG editor shows html code by default

Hi @Uurtsaikh2017

 

Well after doing some resarch on it - i found that by default there is no way to enable wysiwyg editor default on the product attribute page.

 

if its cms page then magento 2 have settings from store -> configuration -> General -> content management system ->wysiwyg settings -> enabled as default

 

But to do the same thing on the product attribute page - you need to customize it on javascript level.

 

Below i am sharing links which might help you to do the same :

 

https://magento.stackexchange.com/questions/176025/how-to-add-show-hide-editor-for-custom-attribute-...

 

https://magento.stackexchange.com/questions/109520/make-wysiwyg-as-default

 

https://stackoverflow.com/questions/20304960/how-to-enable-wysiwyg-by-default-on-textarea-in-admin

 

Hope it helps !

if issue solved,Click Kudos & Accept as Solution

Re: Backend WYSIWYG editor shows html code by default

I gave a kudo and made it accepted solution.

Thank you,

Tom

Re: Backend WYSIWYG editor shows html code by default

Hi @Uurtsaikh2017

 

Happy to help and keep helping Smiley Happy

if issue solved,Click Kudos & Accept as Solution