cancel
Showing results for 
Search instead for 
Did you mean: 

Backend links no not work – lots of jquery errors after installing in Plesk

Backend links no not work – lots of jquery errors after installing in Plesk

Hi, I am trying to install Magento 2.0.1 without sample data in Plesk 12.5. I have managed to install it successfully but I am getting loads of errors on the frontend and back. I have tried deleting the content of pub/static and also replacing the path below for the symlink all to no avail.

 

“Magento\Framework\App\View\Asset\MaterializationStrategy\Symlink” replaces to

“Magento\Framework\App\View\Asset\MaterializationStrategy\Copy”

 

I am unable to click any of the navigation buttons (sales etc) in the backend so im stuck on the welcome page. I have read many threads but I have not found an answer for this. Please can someone help. I am running Centos 7, Apache, php 7.0.2, MariaDB 10. Using debugging tools in FF I can see that there are lot of Script errors please see below. Please can someone help me resolve these.

 

Error: Script error for: jquery

http://requirejs.org/docs/errors.html#scripterror

makeError()

require.js:166

newContext/context.onScriptError()

require.js:1681

require.js:166:17

Error: Script error for: mage/adminhtml/globals

http://requirejs.org/docs/errors.html#scripterror

require.js:166:17

Error: Script error for: Magento_Catalog/catalog/product

http://requirejs.org/docs/errors.html#scripterror

require.js:166:17

Error: Script error for: js/theme

http://requirejs.org/docs/errors.html#scripterror

require.js:166:17

Error: Script error for: mage/backend/bootstrap

http://requirejs.org/docs/errors.html#scripterror

require.js:166:17

Error: Script error for: mage/translate

http://requirejs.org/docs/errors.html#scripterror

require.js:166:17

Error: Script error for: mage/adminhtml/grid

http://requirejs.org/docs/errors.html#scripterror

require.js:166:17

Error: Script error for: Magento_Ui/js/modal/confirm

http://requirejs.org/docs/errors.html#scripterror

require.js:166:17

Error: Script error for: mage/backend/tabs

http://requirejs.org/docs/errors.html#scripterror

require.js:166:17

Error: Script error for: jquery/jquery.cookie

http://requirejs.org/docs/errors.html#scripterror

require.js:166:17

NetworkError: A network error occurred. <unknown>

4 REPLIES

Re: Backend links no not work – lots of jquery errors after installing in Plesk

How to fix the problem of loading css and javascript files: https://mage2.pro/t/259

Re: Backend links no not work – lots of jquery errors after installing in Plesk

Hi and thanks for the links. I tried creating a user and adding it to the apache permissions group, but then I had issues giving the user the correct permissions to the site files as I kept getting permissions denied. I will try again this evening and let you know how I get on.

Re: Backend links no not work – lots of jquery errors after installing in Plesk

Hi thanks for the link, i have managed to get Magento 2 installed after some trial and error. I have a question however as one line in the permissions and ownership section is confusing me.

 

It says “The owner of the Magento file system: Must have full control (read/write/execute) of all files and directories.” However underneath it says Set permissions with :

 

find . -type d -exec chmod 770 {} \; && find . -type f -exec chmod 660 {} \; && chmod u+x bin/magento

 

Shouldn’t the 660 be 760 as 660 is missing the execute permission?

Re: Backend links no not work – lots of jquery errors after installing in Plesk

You can follow below steps and it will be fix.

  1) Set deploy mode to production - **php magento deploy:mode:set production**
       (js and css minification will works with production mode.If you are in developer mode with code minified above issues will show up as I experienced it. If minification disabled you can keep the developer mode. Also verify using echo the print_r($_SERVER) in index.php that production mode or developer mode correctly set before load the website)

  2) Clear all the caches setup in server
        
 - **/etc/init.d/nginx restart**
 - **/etc/init.d/php5.6-fpm restart**
 - **/etc/init.d/varnish restart**
 
3) Clear the browser cache and view it in incognito mode. That's it!

Cheers!