cancel
Showing results for 
Search instead for 
Did you mean: 

Can't install Magento 2 on PHP 5.6.30

SOLVED

Can't install Magento 2 on PHP 5.6.30

Could anyone help me with installation on Magento 2 on my host? I'm new to this platform, used Joomla before. It's gonna be my first installation but I have a problem already. All files are on host but I got this message: 

Magento supports PHP 7.0.2, 7.0.4, and 7.0.6 or later. Please read Magento System Requirements.

Link to the site:

https://finegifts.no/

Host settings:

https://finegifts.no/test.php

 

As you see my host uses php 5.6.30 and in the message it says M2 supports from php 7.

but as you click on system req. you see that 5.6 is still supported so I don't really get it.

 

What you guys think is the problem? Many thanks

8 REPLIES

Re: Can't install Magento 2 on PHP 5.6.30

The link http://devdocs.magento.com/guides/v2.0/install-gde/system-requirements-tech.html is for magento 2.0 which still supported php 5.6

 

You probably want to install magento 2.2 which doesn't (see http://devdocs.magento.com/guides/v2.2/install-gde/system-requirements-tech.html )

Re: Can't install Magento 2 on PHP 5.6.30

I see, the links inside of the magento installer are pointing to the wrong version. I made a PR for this here https://github.com/magento/magento2/pull/12857

Re: Can't install Magento 2 on PHP 5.6.30

Thanks, Thats what I figured, I installed M1.9 instead Smiley Happy

Re: Can't install Magento 2 on PHP 5.6.30

you're welcome.

 

Please be aware, that  is it difficult to migrate to Magento 2.2 from 1.9 later, so it might be a better idea to install PHP 7.1 on your host instead (or ask your provider to update it)

Re: Can't install Magento 2 on PHP 5.6.30

I used your changes. I have still the same problem. 

Re: Can't install Magento 2 on PHP 5.6.30

You ever figure this out? I have the same issue. I have 7.1 installed but Magento installer refuses to see it. Magento installer stops at "Magento supports PHP 7.0.2, 7.0.4, and 7.0.6 or later. Please read....".

 

Magento 2.2 keeps seeing the php5.6 as it is our server default. How do I force Magento to see php7.1 I installed already? We have 2 Magento sites on our server now on version 2.1. Horrible If I can not upgrade them and forced to move them to a different server. We have other sites that had issues when we defaulted the server to 7.1. 

Thanks!

Re: Can't install Magento 2 on PHP 5.6.30

hello, I'm experiencing the same thing. was there a solution to this?

Re: Can't install Magento 2 on PHP 5.6.30

Hi have you solved it yet ? Which OS are you running ? If it's Ubuntu have tried to switch php versions ? Take a look at this link 

 

https://tecadmin.net/switch-between-multiple-php-version-on-ubuntu/