cancel
Showing results for 
Search instead for 
Did you mean: 

Catalog search returns empty when searching a newly added product

SOLVED
Highlighted

Catalog search returns empty when searching a newly added product

I have inserted new products and put under the category "simple". But when I tried to search "simple" it will just return "Your search returned no results." Any idea how I can resolved this?

The product actually exist as I tried to reach it directly by the url link and it works. Just seems to be missing from the search.Screenshot 2020-06-29 at 12.29.24 PM.png

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Re: Catalog search returns empty when searching a newly added product

@kvnwong0gm7474 

 

Please check your elastic search connection Magento admin> store>configuration > catalog > catalog search and check elastic search connection is fine or not. It might be the issue.

Manish Mittal
https://www.manishmittal.com/

View solution in original post

10 REPLIES 10
Highlighted

Re: Catalog search returns empty when searching a newly added product

Hi @kvnwong0gm7474 

 

Please check following points:

 

1. Product is set to enabled under status
2. Product is set to catalog (and search) under visibilty
3. Product has qty (in stock) and set to in stock
4. Product is attached to a category
5. Then run a "Empty cache" and a re-index.

php bin/magento indexer:reindex
php bin/magento cache:flush

It may help you to resolve issue.
If issue resolve, please click on 'Kudos' & Accept as Solution!

Highlighted

Re: Catalog search returns empty when searching a newly added product

@Bhanu Periwal I did everything as followed. The issue seems to still persist.
Hmm could it be something else? I checked the query that it runs, seems to limit to the first 100 products only to index into the catalogsearch_fulltext_scope table

Highlighted

Re: Catalog search returns empty when searching a newly added product

@kvnwong0gm7474 

 

Please check your elastic search connection Magento admin> store>configuration > catalog > catalog search and check elastic search connection is fine or not. It might be the issue.

Manish Mittal
https://www.manishmittal.com/

View solution in original post

Highlighted

Re: Catalog search returns empty when searching a newly added product

@Manish Mittal upon checking, seems like I am not using elastic search. I am using MySQL search. Any idea what could affect this?

Highlighted

Re: Catalog search returns empty when searching a newly added product

Hi @kvnwong0gm7474 

 

I understand that you are not using elastic search and using only the MySQL search of the Magento.

 

As you mentioned that you have created the products and that product you have added into the category name called "Simple", So here you are searching by category name, not by-products name.

 

So I would suggest you enter the product name in the search and then check it will return your products in the search results. (Ex: your product name is "ABC" then search for ABC) it will showcase your products into the search results.

 

Also don't forgot to run indexer and cache clean command after saving all your products/categories.

 

I hope it helps! 

 

if issue solved,Click Kudos & Accept as Solution
Highlighted

Re: Catalog search returns empty when searching a newly added product

@kvnwong0gm7474 

 

Is this product showing in listing product?

Manish Mittal
https://www.manishmittal.com/
Highlighted

Re: Catalog search returns empty when searching a newly added product

 


@kvnwong0gm7474 wrote:

@Manish Mittal upon checking, seems like I am not using elastic search. I am using MySQL search. Any idea what could affect this?


Might possible you have missed to execute indexer command

Highlighted

Re: Catalog search returns empty when searching a newly added product

Hi @Manthan Dave,


I have tried searching for exact product name and it still showing "no results".

Reindexed and cache cleaned, still getting "no results".

Highlighted

Re: Catalog search returns empty when searching a newly added product

@Manish Mittal 

Unfortunately, it does seems to appear there either. But it does appear at the storefront when I featured it. Any idea what might caused it?