cancel
Showing results for 
Search instead for 
Did you mean: 

Checkout not loading

Checkout not loading

I've just done a brand new frsh install of Magento 2.2.4 and migrated my settings and data from the 1.9 version of the site. Luma theme (also tried Blank). Default mode. Cron jobs are running.

No extensions have been installed so far.

I've set up 1 payment type (bank transfer).

Shipping is set to flat rate.

When I add a product to the cart and try to checkout the checkout page does not load properly. All I can see is the logo and the copyright text in the footer. Everything else is white.

I've tried turning off javascript and css merge, disabled the caches, reindexed, nothing works.

There's no errors in the web inspector console, nothing in the logs, nothing in the server error log.

Help!

6 REPLIES

Re: Checkout not loading

Try with gives full permission to magento 2 store,

find . -type d -exec chmod 755 {} \; && find . -type f -exec chmod 644 {} \; && chmod u+x bin/magento

Run below command using SSH,

php bin/magento setup:upgrade
php bin/magento setup:static-content:deploy -f
php bin/magento cache:flush

 

 

If Issue Solved, Click Kudos/Accept As solutions.

Re: Checkout not loading

No, that didn't work.

Re: Checkout not loading

Hi @denialdesign,

 

What if you change mode to production?

Also, if everything is blank maybe some 404 on some resoruces? CAn you check the network requests on your browser?

--
If you've found one of my answers useful, please give "Kudos" or "Accept as Solution"

Re: Checkout not loading

Production mode didn't make a difference.

There are no 404 errors on any resources. It looks like everything is being requested correctly but nothing is being rendered other than the logo and copyright message.

Re: Checkout not loading

Have you checked your magento root with .htaccess file is available or not? if not add to your root of magento.

If Issue Solved, Click Kudos/Accept As solutions.

Re: Checkout not loading

Yes, the .htaccess is there.

I've also tried checkout with multiple addresses and that fails on the Billing Address stage. White page, just the logo, copyright and Billing Address header this time. Again there's no errors, no 404 files.