cancel
Showing results for 
Search instead for 
Did you mean: 

Component Dependency Error Installing Free Yume Theme (Magento 2.1.3)

Component Dependency Error Installing Free Yume Theme (Magento 2.1.3)

I'm trying to install the free Venus Yume Theme using the Component Manger, but keep getting this error during the 'Readiness Check.' I haven't been able to find a solution yet. Any recommendations are appreciated.

 

Check Component Dependency

We found conflicting component dependencies. Hide detail

Command "update" failed: Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

Problem 1
- Installation request for magento/product-community-edition 2.1.3 -> satisfiable by magento/product-community-edition[2.1.3].
- venustheme/theme-frontend-yume 100.0.1 requires magento/framework 100.0.* -> satisfiable by magento/framework[100.0.10, 100.0.11, 100.0.12, 100.0.13, 100.0.2, 100.0.3, 100.0.4, 100.0.5, 100.0.6, 100.0.7, 100.0.8, 100.0.9].
- Can only install one of: magento/framework[100.1.3, 100.0.10].
- Can only install one of: magento/framework[100.1.3, 100.0.11].
- Can only install one of: magento/framework[100.1.3, 100.0.12].
- Can only install one of: magento/framework[100.1.3, 100.0.13].
- Can only install one of: magento/framework[100.1.3, 100.0.2].
- Can only install one of: magento/framework[100.1.3, 100.0.3].
- Can only install one of: magento/framework[100.1.3, 100.0.4].
- Can only install one of: magento/framework[100.1.3, 100.0.5].
- Can only install one of: magento/framework[100.1.3, 100.0.6].
- Can only install one of: magento/framework[100.1.3, 100.0.7].
- Can only install one of: magento/framework[100.1.3, 100.0.8].
- Can only install one of: magento/framework[100.1.3, 100.0.9].
- magento/product-community-edition 2.1.3 requires magento/framework 100.1.3 -> satisfiable by magento/framework[100.1.3].
- Installation request for venustheme/theme-frontend-yume 100.0.1 -> satisfiable by venustheme/theme-frontend-yume[100.0.1].

For additional assistance, see component dependency help .

 

5 REPLIES

Re: Component Dependency Error Installing Free Yume Theme (Magento 2.1.3)

Hi @scamp772,

 

It's a problem with the dependencies defined on composer.json.

You'll need to request support (or, at least, show this problem) to the author. I guss that you'll find some cotnact information on that file too.

 

They defined some dependencies with some specific versions of modules.

--
If you've found one of my answers useful, please give "Kudos" or "Accept as Solution"

Re: Component Dependency Error Installing Free Yume Theme (Magento 2.1.3)

I wound up downloading the theme and uploading the files directly through cPanel per the instructions within their README.txt file and it seems to be working now.

Re: Component Dependency Error Installing Free Yume Theme (Magento 2.1.3)

Hi.

 

I'm having the same issue, how did you manage to download it?

 

I'm not finding that option.

 

Can you help please?

Re: Component Dependency Error Installing Free Yume Theme (Magento 2.1.3)

Stuck up with same issue. Can you explain how to do that? Any help will be appreciated.

Re: Component Dependency Error Installing Free Yume Theme (Magento 2.1.3)