cancel
Showing results for 
Search instead for 
Did you mean: 

Database user does not have enough privileges..

Database user does not have enough privileges..

Database user does not have enough privileges. Please make sure SELECT, INSERT, UPDATE, DELETE, CREATE, DROP, REFERENCES, INDEX, ALTER, CREATE TEMPORARY TABLES, LOCK TABLES, EXECUTE, CREATE VIEW, SHOW VIEW, CREATE ROUTINE, ALTER ROUTINE, EVENT, TRIGGER privileges are granted to table 'database_name'

 

Why Magento 2.x doesn't work with Dreamhost? As we talked to dreamhost support, Magento 2.0's MySQL usage requires a TRIGGER privilege that they don't allow at this time due to security concerns.

 

my Question is, why magento released such type of version that some hosting companies don't allow? What's the use? What's the fix?

 

 

6 REPLIES 6

Re: Database user does not have enough privileges..

Same issue her.

But for it happened out of the blue.

Admin url says: 

Exception #0 (LogicException): Front controller reached 100 router match iterations

when i try to run

php bin/magento setup:upgrade

[Magento\Setup\Exception]                                                                                                                                                                             

  Database user does not have enough privileges. Please make sure SELECT, INSERT, UPDATE, DELETE, CREATE, DROP, REFERENCES, View, ALTER, CREATE TEMPORARY TABLES, LOCK TABLES, EXECUTE, CREATE VIEW, S 

  HOW VIEW, CREATE ROUTINE, ALTER ROUTINE, EVENT, TRIGGER privileges are granted to table 'dev'. 

 

relentless magento error 😕

 

Re: Database user does not have enough privileges..

Check into my.ini file in MySql config section and check whether skip-grant-tables is there below

# The MySQL server
[mysqld]

........

If it is there then delete it and restart the server. 

hope it will sort out the issue.

Re: Database user does not have enough privileges..

Ok, good to go.

Re: Database user does not have enough privileges..

I was getting the following error on accessing http://localhost/phpmyadmin 

 

 

MySQL said: Documentation

Cannot connect: invalid settings.
 mysqli_real_connect(): (HY000/1130): Host 'localhost' is not allowed to connect to this MariaDB server
 Connection for controluser as defined in your configuration failed.
 mysqli_real_connect(): (HY000/1130): Host 'localhost' is not allowed to connect to this MariaDB server
 phpMyAdmin tried to connect to the MySQL server, and the server rejected the connection. You should check the host, username and password in your configuration and make sure that they correspond to the information given by the administrator of the MySQL server.

 

so I added 'skip-grant-tables' in my.ini and I can access now. However While installing the Magento2 in the xampp server, I am receiving the following error :

        

Database user does not have enough privileges. Please make sure SELECT, INSERT, UPDATE, DELETE, CREATE, DROP, INDEX, ALTER, CREATE TEMPORARY TABLES, LOCK TABLES, EXECUTE, CREATE VIEW, SHOW VIEW, CREATE ROUTINE, ALTER ROUTINE, TRIGGER privileges are granted to database 'magento2'.

 Will I not be able to install Magento unless 'skip-grant=tables' is removed? But after doing so I am not able to even access phpmyadmin. What is supposed to be done to solve the issue?

 

Re: Database user does not have enough privileges..

You can give full permission to % and localhost both and check it.

Re: Database user does not have enough privileges..

Database user does not have enough privileges. Please make sure SELECT, INSERT, UPDATE, DELETE, CREATE, DROP, INDEX, ALTER, CREATE TEMPORARY TABLES, LOCK TABLES, EXECUTE, CREATE VIEW, SHOW VIEW, CREATE ROUTINE, ALTER ROUTINE, TRIGGER privileges are granted to database 'Database name'.

 

if you also got this type of errors. in my.ini file find "skip-grant-tables" if it is there then remove it and restart xampp.

 

This is working fine. I have added skip-grant-tables for some reason that's why this errors are showing. remove it and restart the xampp server so it will work fine.