cancel
Showing results for 
Search instead for 
Did you mean: 

Error on upgrade form Magento 2.2.1 to 2.2.4 or 2.2.5

Error on upgrade form Magento 2.2.1 to 2.2.4 or 2.2.5

Hi,

ugraging form composer I have always the same error on "Module 'Magento_Sales'":

 

Module 'Magento_Authorization':
Module 'Magento_Sales':
Upgrading data..
Check https://getcomposer.org/doc/articles/troubleshooting.md#memory-limit-errors for more info on how to handle out of memory errors

 

I have the same error on different server, I setup also more PHP memory (also no limits) but the result is alway the same.

 

Anyone has a solution for this?

 

thanks
Piero

2 REPLIES

Re: Error on upgrade form Magento 2.2.1 to 2.2.4 or 2.2.5

Hi @calamusdesign

 

Well including memory , you also need to increase value of max_execution_time as well !

 

So below is the configuration which you need to increase from php.ini file 

 

in your php.ini file configuration should be like below :

 

max_execution_time = 18000
max_input_time = 18000
memory_limit = 1024M

For more details you can refer this link for the same - https://community.magento.com/t5/Installing-Magento-2-x/Magento-2-Installation-error-at-66/td-p/9232...

if issue solved,Click Kudos & Accept as Solution

Re: Error on upgrade form Magento 2.2.1 to 2.2.4 or 2.2.5

Hi,

this setting solve the error but after 24h the process still on
"update Module 'Magento_Sales':
Upgrading data..


So I have stopped the process.


Any idea?
Thanks
Piero