cancel
Showing results for 
Search instead for 
Did you mean: 

First-Class Mail Parcel no longer shows up

First-Class Mail Parcel no longer shows up

I just noticed that First-Class Mail Parcel no longer shows up. I guess USPS must have just made changes? I think it has been changed to - First-Class Package Service - Retail. I can't find any updates for Magento to fix this issue. Does anyone have any insight? I am running Community v1.9.3.4

6 REPLIES

Re: First-Class Mail Parcel no longer shows up

See our blog post http://blog.shipperhq.com/2017/09/usps-api-changes-sept-1st-2017/

 

Has details and fix for Magento.

 

Rgds

 

Karen

Re: First-Class Mail Parcel no longer shows up

Awesome! Thanks for helping! 

I am running Magento Community v1.9.3.4 and my location is not as you referenced above.

You have – Look for the file app/code/core/Mage/Usa/Mode/Shipping/Carrier/Usps.php

I have – app/code/core/Mage/USA/Model/Shipping/Carrier/Usps.php

I guess it's just a typo. I found - First-Class Mail Parcel on line 703 & 543 Do we just change the entry on 703 only or both lines?

Sorry I'm not an expert on this and I just want to make sure I don't mess up anything :-)

 

Update - I did the update as per your web page ref and changed the code on both lines but you have to use - 

First-Class Package Service - Retail

If you use the code on your web page it won't work because the dash is not the correct one. (The one between Service & Retail) I saw this in Notepad and put them one on top of the other and saw the dash is just a little bit longer. The one above in my reference here is the shorter one and it works.

Re: First-Class Mail Parcel no longer shows up

Does anyone have a solution for Magento 1.7.2? The Usps.php  file in my magento version doesn't have the similar method_codes.... and I tried replacing the 'First-Class Mail Parcel' with 

First-Class Package Service - Retail

but I do not see it in my shipping method dropdown. Any help is much appreciated 

Re: First-Class Mail Parcel no longer shows up

Similar problem here with 1.9.2.1.

One step in the link shown in the 2nd message in this thread is to "refresh the shipping methods" in the Magento configuration area. Anyone know how to do that???

Also, I am using commercial rates rather than retail, so the term I should be using might be "First-Class Package Service - Commercial" or just "First-Class Package"

Still struggling through what seems like it should be a small fix!

Re: First-Class Mail Parcel no longer shows up

Actually, I'm not using commercial rates...could never get that fix to work.

 

Still can't get my First-Class Package rate to show up again. I followed the instructions in http://devdocs.magento.com/guides/v2.1/release-notes/tech_bull_USPS-patch-Sept2017.html. The rates are being sent to the postal service and the results come back properly...I checked the log...but I can't get it to show up in the config screen so I can choose it. 

 

I could try the patch but I need help here too.  "Enter the following commands as a user with sufficient privileges to write to Magento files (typically, the web server user or root):

chmod +x <patch-file-name>.sh
./<patch-file-name>.sh

I don't know where to enter these commands.....   help requested. 

very discouraged.

Re: First-Class Mail Parcel no longer shows up

As this relates to USPS Commercial based rates (that allow first class postage on packages between 12 oz to 15.99 oz) in Magento 2 ... here is a related post: https://community.magento.com/t5/Technical-Issues/USPS-First-Class-Commercial-Based-Rates-Not-Showin...