cancel
Showing results for 
Search instead for 
Did you mean: 

Fresh Magento 2 Install, constantly getting a "Please Wait..." loading in Admin

Fresh Magento 2 Install, constantly getting a "Please Wait..." loading in Admin

So I just got Magento 2 installed, but when I attempt to do simple tasks such as update the master user password (in the Admin), I get a "Please Wait..." loading sprite and nothing happens...

 

Or I go to 'Sales' or 'Orders', I just get a loading sprite, again.  Really can't do much in the Admin control panel right now.  How can I fix this?  I do have a cache software installed as well

7 REPLIES

Re: Fresh Magento 2 Install, constantly getting a "Please Wait..." loading in Admin

Anybody?

Re: Fresh Magento 2 Install, constantly getting a "Please Wait..." loading in Admin

See the diagnistic report in the browser console: https://mage2.pro/t/278

Re: Fresh Magento 2 Install, constantly getting a "Please Wait..." loading in Admin

Thank you.


For what it is worth, this is what is showing in the error console in Chrome when logged into Admin panel:

 

jquery-migrate.js:21 JQMIGRATE: Logging is active
http://magento2.cctdefense.net/pub/static/adminhtml/Magento/backend/en_US/Magento_Ui/templates/modal... Failed to load resource: the server responded with a status of 404 (Not Found)
http://magento2.cctdefense.net/pub/static/adminhtml/Magento/backend/en_US/Magento_Ui/templates/modal... Failed to load resource: the server responded with a status of 404 (Not Found)
http://magento2.cctdefense.net/pub/static/adminhtml/Magento/backend/en_US/Magento_Ui/templates/modal... Failed to load resource: the server responded with a status of 404 (Not Found)
jquery.js:9627 Synchronous XMLHttpRequest on the main thread is deprecated because of its detrimental effects to the end user's experience. For more help, check http://xhr.spec.whatwg.org/.
jquery-migrate.js:41 JQMIGRATE: jQuery.attrFn is deprecated
jquery-migrate.js:43 console.trace()migrateWarn @ jquery-migrate.js:43
http://magento2.cctdefense.net/pub/static/adminhtml/Magento/backend/en_US/Magento_Ui/js/core/rendere... Failed to load resource: the server responded with a status of 404 (Not Found)
require.js:141 Uncaught Error: Script error for: Magento_Ui/js/core/renderer/layout
http://requirejs.org/docs/errors.html#scripterror
http://magento2.cctdefense.net/pub/static/adminhtml/Magento/backend/en_US/Magento_Ui/js/core/rendere... Failed to load resource: the server responded with a status of 404 (Not Found)
require.js:141 Uncaught Error: Script error for: Magento_Ui/js/core/renderer/types
http://requirejs.org/docs/errors.html#scripterror
http://magento2.cctdefense.net/pub/static/adminhtml/Magento/backend/en_US/Magento_Ui/js/lib/ko/initi... Failed to load resource: the server responded with a status of 404 (Not Found)
require.js:141 Uncaught Error: Script error for: Magento_Ui/js/lib/ko/initialize
http://requirejs.org/docs/errors.html#scripterror
http://magento2.cctdefense.net/pub/static/frontend/Magento/luma/en_US/Magento_Checkout/js/checkout-l... Failed to load resource: the server responded with a status of 404 (Not Found)
require.js:141 Uncaught Error: Script error for: Magento_Checkout/js/checkout-loader
http://requirejs.org/docs/errors.html#scripterror
http://magento2.cctdefense.net/pub/static/frontend/Magento/luma/en_US/Magento_Customer/js/section-co... Failed to load resource: the server responded with a status of 404 (Not Found)
require.js:141 Uncaught Error: Script error for: Magento_Customer/js/section-config
http://requirejs.org/docs/errors.html#scripterror
http://magento2.cctdefense.net/pub/static/frontend/Magento/luma/en_US/Magento_PageCache/js/page-cach... Failed to load resource: the server responded with a status of 404 (Not Found)
require.js:141 Uncaught Error: Script error for: Magento_PageCache/js/page-cache
http://requirejs.org/docs/errors.html#scripterror
http://magento2.cctdefense.net/pub/static/frontend/Magento/luma/en_US/Magento_Customer/js/customer-d... Failed to load resource: the server responded with a status of 404 (Not Found)
require.js:141 Uncaught Error: Script error for: Magento_Customer/js/customer-data
http://requirejs.org/docs/errors.html#scripterror
http://magento2.cctdefense.net/pub/static/frontend/Magento/luma/en_US/Magento_Ui/js/lib/ko/template/... Failed to load resource: the server responded with a status of 404 (Not Found)
require.js:141 Uncaught Error: Script error for: Magento_Ui/js/lib/ko/template/loader
http://requirejs.org/docs/errors.html#scripterror

Re: Fresh Magento 2 Install, constantly getting a "Please Wait..." loading in Admin

How to fix the problem of loading css and javascript files: https://mage2.pro/t/259 

Re: Fresh Magento 2 Install, constantly getting a "Please Wait..." loading in Admin

Hmm,

 

from my hosting support:

 

"Not sure what else I can do here. The permissions are not the problem. There are errors in the log such as:

[Tue Dec 15 10:04:05.460298 2015] [core:error] [pid 8107] [client 50.30.61.36:41739] AH00037: Symbolic link not allowed or link target not accessible: /home/cctdefen/public_html/magento2/pub/static/adminhtml/Magento/backend/en_US/Magento_AdminNotification/toolbar_entry.js, referer: http://magento2.cctdefense.net/admin_a15f8c/sales/order/index/key/8b37c96b5e5c4d57a41802039d03a27f49...

I fixed that by copying the correct file it was looking for, but there are many other similar errors and ones like this:

[Tue Dec 15 10:08:09.726587 2015] [core:crit] [pid 8098] (13)Permission denied: [client 50.30.61.36:41987] AH00529: /home/cctdefen/public_html/magento2/pub/static/adminhtml/Magento/backend/en_US/Magento_Ui/js/core/renderer/.htaccess pcfg_openfile: unable to check htaccess file, ensure it is readable and that '/home/cctdefen/public_html/magento2/pub/static/adminhtml/Magento/backend/en_US/Magento_Ui/js/core/renderer/' is executable, referer: http://magento2.cctdefense.net/admin_a15f8c/sales/order/index/key/8b37c96b5e5c4d57a41802039d03a27f49...

There is no .htacess file there. I am not sure what is up with this but I do not think this is easily fixable without a re-install of Magento or help from their developers. I think something quite odd may have happened.."

Re: Fresh Magento 2 Install, constantly getting a "Please Wait..." loading in Admin

 

The issue is related to file permissions.  Magento auto sets file perms to the recommended so if you have php setup where it requires different folder and file permissions you will inevitably run into issues.

 

The problem relates to the pub directory where the static files are being produced but because the perms are wrong magento is unable to create the necessary files which then results in the errors because the file isn;t being created



Have a magento store? Want to track your SEO positions? Try WordTail for free

Re: Fresh Magento 2 Install, constantly getting a "Please Wait..." loading in Admin

Had the same problem. It is a problem with the file and directory permissions.

Are all permissions as recommended in the Documentation?

 

Is the user running apache (check which user that actually is) in the same group as the one group you granted permissions?

E.g. I granted permission to group psacln, but apache2 is run under www-data... And User www-data is not member in group psacln.

Seems to be a problem in combination with Plesk.