cancel
Showing results for 
Search instead for 
Did you mean: 

Google API settings for Google Analytics and AdWords are not working

Highlighted

Google API settings for Google Analytics and AdWords are not working

Hello,

 

I have placed the information for Google Analytics and AdWords on Stores->Configuration->Sales->Google API as "Default Config". Unfortunately Chrome Google Tag Assistant shows error. It finds only the Analytics Property but with error. It says "Same web property ID is tracked twice." But in the sourcecode there is just one correct property. Also I cannot see the AdWords ID.

 

Shop URL: https://comfortbaby.global

 

How can this be fixed?

 

Gruß

Hueseyinimage.png

 

8 REPLIES

Re: Google API settings for Google Analytics and AdWords are not working

@hueseyin_u

I guess you good.

image.png

 

 

 

Problem solved? Please give 'Kudos' and accept 'Answer as Solution'.

 

Thanks,
Tarandeep
Magento 2 Certified Solution Specialist (x2). Follow me on Twitter

Re: Google API settings for Google Analytics and AdWords are not working

No, it works now because I have to place the tracking code manually under Content->Design->Configuration->HTML Head->Scripts and Style Sheets

 

Google API entries are still not working. Also I don't know where to place the AdWords tracking code.

Re: Google API settings for Google Analytics and AdWords are not working

I believe you are using Magento 2. Please follow the below URL to see how to configure Google Analytics and Google Adwords in Magento.

 

http://docs.magento.com/m2/ce/user_guide/marketing/google-tools.html

 

Problem solved? Please give 'Kudos' and accept 'Answer as Solution'.

 

 

Thanks,
Tarandeep
Magento 2 Certified Solution Specialist (x2). Follow me on Twitter

Re: Google API settings for Google Analytics and AdWords are not working

Yes we are using Magento 2.2.1 actually.

 

I have read and followed this and many other documentations. It really doesn't work. AdWords is not tracking any conversions. Conversions are '0' although there are approx. 10 orders per day. The Analytics code is allegedly seen twice in the source code.

 

Actually the Google API is disabled and the property for Analytics is placed in HTML Head temporarily.

 

I would really appreciate to get help.

Re: Google API settings for Google Analytics and AdWords are not working

I am using default Magento integration on many websites and it works fine. Can you give it a try again? Once you configure it via Magento did you refresh the cache and confirmed that analytic  code is appearing or not?

 

Problem solved? Please give 'Kudos' and accept 'Answer as Solution'.

 

Thanks,
Tarandeep
Magento 2 Certified Solution Specialist (x2). Follow me on Twitter

Re: Google API settings for Google Analytics and AdWords are not working

Ok, I have tested again. Now I have placed the Analytics property again and removed the tracking code from HTML Head

 

Screenshot1.jpg

 

and unfortunately get the same result again Smiley Sad

 

image.png

Re: Google API settings for Google Analytics and AdWords are not working

Another weird thing is that if I remove the entries in Google API and also don't place the tracking snippet of Analytics under HTML Header Tag Assistant shows that ther is a Remarketing Tag on the website. And I don't know this tag.

 

image.png

Re: Google API settings for Google Analytics and AdWords are not working

For some reason I do not see the screenshot. I guess you are using combined JS as well. I believe you would have to deploy the static content again after making the changes.

 

I would recommend perform this on the a test server first and see if that resolves your issue. This is what you need to do:

 

php bin/magento cache:flush
php bin/magento setup:static-content:deploy

Problem solved? Please give 'Kudos' and accept 'Answer as Solution'.

Thanks,
Tarandeep
Magento 2 Certified Solution Specialist (x2). Follow me on Twitter